View Issue Details

IDProjectCategoryView StatusLast Update
0002899SymmetricDSBugpublic2019-08-26 08:45
ReporternuralimcaAssigned Toelong 
Prioritynormal 
Status closedResolutionopen 
Product Version3.7.33 
Target VersionFixed in Version 
Summary0002899: MAINTENANCE TOKEN error from sybase pause data copy
DescriptionHi,

I am using ..
Symmetric DS: 3.7.33
Source DB: Sybase ASE 15
Source JDBC Driver: jTDS 1.3
Target DB: Sybase ASE 16
Target JDBC Driver: JConnect 7.07

When data are getting copied from Source DB to Target DB, sometimes I got "MAINTENANCE TOKEN" error due to which data copy from source to target don't happen. After sometime (about 10 mins), the "MAINTENANCE TOKEN" issue goes off and data copy contiunues as usual by Symmteric DS.

** Error **
2016 11 04 03:34:34#+00#DEBUG#com.sap.it.setup.migrate2.core.db.DbDeltaCopyCompletedCheckSupplier##anonymous#AvatarMigrationThread-1#na#wb38a11ed#vnsdsload4#web#wb38a11ed#RouterService.unroutedDataCount:1|
2016 11 04 03:34:36#+00#ERROR#org.jumpmind.symmetric.service.impl.RouterService##anonymous#tnt1_rt-0000-job-8#na#wb38a11ed#vnsdsload4#web#wb38a11ed#org.jumpmind.db.sql.SqlException: Operand type clash: DECIMAL is incompatible with MAINTENANCE TOKEN
 
                at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:283)
                at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:274)
                at org.jumpmind.db.sql.JdbcSqlTransaction.flush(JdbcSqlTransaction.java:163)
                at org.jumpmind.symmetric.service.impl.DataService.insertDataEvents(DataService.java:978)
                at org.jumpmind.symmetric.service.impl.RouterService.routeDataForChannel(RouterService.java:512)
                at org.jumpmind.symmetric.service.impl.RouterService.routeDataForEachChannel(RouterService.java:336)
                at org.jumpmind.symmetric.service.impl.RouterService.routeData(RouterService.java:184)
                at org.jumpmind.symmetric.job.RouterJob.doJob(RouterJob.java:40)
                at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:180)
                at org.jumpmind.symmetric.job.AbstractJob.run(AbstractJob.java:224)
                at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:53)
                at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
                at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:304)
                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:178)
                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
                at java.lang.Thread.run(Thread.java:812)
Caused by: java.sql.BatchUpdateException: Operand type clash: DECIMAL is incompatible with MAINTENANCE TOKEN
 
                at net.sourceforge.jtds.jdbc.JtdsStatement.executeBatch(JtdsStatement.java:1069)
                at org.apache.commons.dbcp.DelegatingStatement.executeBatch(DelegatingStatement.java:297)
                at org.apache.commons.dbcp.DelegatingStatement.executeBatch(DelegatingStatement.java:297)
                at org.jumpmind.db.sql.JdbcSqlTransaction.flush(JdbcSqlTransaction.java:156)
                ... 15 common frames omitted
|


Some more details:

I have observed that above exception happened when below query is getting executed.
Query - insert into sym_data_event (data_id, batch_id, router_id, create_time) values(?, ?, ?, getdate())

As insert to sym_data_event keep failing, NO more new outgoing batches created and thus NO data copy happened during the time when "MAINTENANCE TOKEN" issue occurred.

Let me know in case need more details.

Cheers,
Nurali


Steps To ReproduceIssue comes up sometimes when data copy is happening from Source DB to Target DB.
Tagsdialect: sybase

Activities

elong

2019-04-24 10:06

developer   ~0001426

This sounds more like a Sybase issue than something SymmetricDS caused. Does it help if you set a SQL statement to run with the "db.init.sql" property in your engine's file? When it creates a new connection to the database, it will first run that statement on the connection. Does it help to reduce the size of the connection pool also? See db.pool.max.active parameter.

admin

2019-08-26 08:45

administrator   ~0001587

Auto closing all issues waiting for feedback after 4 months. We don't have enough information to take any action.

Issue History

Date Modified Username Field Change
2016-11-14 00:50 nuralimca New Issue
2019-04-24 10:06 elong Assigned To => elong
2019-04-24 10:06 elong Status new => feedback
2019-04-24 10:06 elong Note Added: 0001426
2019-04-24 10:08 elong Tag Attached: dialect: sybase
2019-08-26 08:45 admin Note Added: 0001587
2019-08-26 08:45 admin Status feedback => closed