View Issue Details

IDProjectCategoryView StatusLast Update
0002948SymmetricDSBugpublic2016-12-30 08:10
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.11 
Target Version3.8.12Fixed in Version3.8.12 
Summary0002948: Columns mismatched with multiline clob and varchar columns with matching protocol data that happens to be in a new line
Descriptionjava.lang.RuntimeException: Could not convert a value of Laura for column dtveloff of type NUMERIC
    at org.jumpmind.db.platform.AbstractDatabasePlatform.getObjectValues(AbstractDatabasePlatform.java:374)
    at org.jumpmind.symmetric.io.data.writer.DefaultDatabaseWriter.execute(DefaultDatabaseWriter.java:802)
    at org.jumpmind.symmetric.io.data.writer.DefaultDatabaseWriter.update(DefaultDatabaseWriter.java:459)
    at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.write(AbstractDatabaseWriter.java:156)
    at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
    at org.jumpmind.symmetric.model.ProcessInfoDataWriter.write(ProcessInfoDataWriter.java:65)
    at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
    at org.jumpmind.symmetric.io.data.writer.TransformWriter.write(TransformWriter.java:207)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachDataInTable(DataProcessor.java:200)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachTableInBatch(DataProcessor.java:170)
    at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:116)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener$1.call(DataLoaderService.java:936)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener$1.call(DataLoaderService.java:911)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NumberFormatException
    at java.math.BigDecimal.<init>(Unknown Source)
    at java.math.BigDecimal.<init>(Unknown Source)
    at java.math.BigDecimal.<init>(Unknown Source)
    at org.jumpmind.db.platform.AbstractDatabasePlatform.parseBigDecimal(AbstractDatabasePlatform.java:458)
    at org.jumpmind.db.platform.AbstractDatabasePlatform.getObjectValue(AbstractDatabasePlatform.java:413)
    at org.jumpmind.db.platform.AbstractDatabasePlatform.getObjectValues(AbstractDatabasePlatform.java:370)
    ... 16 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 ec54c547

2016-12-24 10:59:05

chenson

Details Diff
0002948: Columns mismatched with multiline clob and varchar columns with
matching protocol data that happens to be in a new line

0002948
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/SimpleStagingDataWriter.java Diff File

SymmetricDS: 3.8 80dfb104

2016-12-24 11:19:08

chenson

Details Diff
0002948: Columns mismatched with multiline clob and varchar columns with
matching protocol data that happens to be in a new line

0002948
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/SimpleStagingDataWriter.java Diff File

Issue History

Date Modified Username Field Change
2016-12-24 10:57 chenson New Issue
2016-12-24 10:57 chenson Status new => assigned
2016-12-24 10:57 chenson Assigned To => chenson
2016-12-24 11:00 chenson Changeset attached => SymmetricDS 3.8 ec54c547
2016-12-24 12:00 chenson Changeset attached => SymmetricDS 3.8 80dfb104
2016-12-26 11:46 chenson Status assigned => resolved
2016-12-26 11:46 chenson Fixed in Version => 3.8.12
2016-12-26 11:46 chenson Resolution open => fixed
2016-12-30 08:10 chenson Status resolved => closed