View Issue Details

IDProjectCategoryView StatusLast Update
0002960SymmetricDSImprovementpublic2017-01-19 14:56
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.13 
Target Version3.8.14Fixed in Version3.8.14 
Summary0002960: Save on memory: StagingManager creates lots of empty maps that just take up memory as staging grows
DescriptionStagingManager creates lots of empty maps that just take up memory as staging grows
TagsNo tags attached.

Activities

chenson

2017-01-14 16:11

administrator   ~0000951

Also make a change to the transformservice cache to create smaller maps

chenson

2017-01-14 16:24

administrator   ~0000952

Also made a change to not create stringbuilder if the threshold for writing to staging is 0

Related Changesets

SymmetricDS: 3.8 7d185b34

2017-01-14 16:12:19

chenson

Details Diff
0002960: Save on memory: StagingManager creates lots of empty maps that
just take up memory as staging grows

0002960
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/TransformService.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File

SymmetricDS: 3.8 46a740c4

2017-01-14 16:25:12

chenson

Details Diff
0002960: made a change to not create stringbuilder if the threshold for
writing to staging is 0

0002960
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/ThresholdFileWriter.java Diff File

SymmetricDS: 3.8 792adf75

2017-01-16 10:14:33

chenson

Details Diff
0002960: Save on memory: StagingManager creates lots of empty maps that
just take up memory as staging grows

0002960
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/io/MsSqlBulkDatabaseWriter.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/io/MySqlBulkDatabaseWriter.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/io/RedshiftBulkDatabaseWriter.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/stage/BatchStagingManager.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/FileSyncExtractorService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/FileSyncService.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/SimpleStagingDataWriter.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/StagingDataWriter.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/IStagedResource.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/IStagingManager.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagingManager.java Diff File

SymmetricDS: 3.8 abee2dc2

2017-01-17 08:14:30

chenson

Details Diff
0002960: Add reference to file back to staged resource because we no
longer keep so many instances in memory.

0002960
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File

SymmetricDS: 3.8 d64a542e

2017-01-18 17:57:21

chenson

Details Diff
0002960: Add reference to file back to staged resource because we no
longer keep so many instances in memory.

0002960
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File

Issue History

Date Modified Username Field Change
2017-01-14 15:50 chenson New Issue
2017-01-14 15:50 chenson Status new => assigned
2017-01-14 15:50 chenson Assigned To => chenson
2017-01-14 16:11 chenson Note Added: 0000951
2017-01-14 16:24 chenson Note Added: 0000952
2017-01-14 16:25 chenson Status assigned => resolved
2017-01-14 16:25 chenson Fixed in Version => 3.8.14
2017-01-14 16:25 chenson Resolution open => fixed
2017-01-14 17:00 chenson Changeset attached => SymmetricDS 3.8 46a740c4
2017-01-14 17:00 chenson Changeset attached => SymmetricDS 3.8 7d185b34
2017-01-16 11:00 chenson Changeset attached => SymmetricDS 3.8 792adf75
2017-01-17 09:00 chenson Changeset attached => SymmetricDS 3.8 abee2dc2
2017-01-18 19:00 chenson Changeset attached => SymmetricDS 3.8 d64a542e
2017-01-19 14:56 chenson Status resolved => closed