View Issue Details

IDProjectCategoryView StatusLast Update
0002980SymmetricDSImprovementpublic2019-05-14 13:15
ReporterchensonAssigned Tochenson 
Prioritynormal 
Status closedResolutionduplicate 
Product Version3.9.1 
Target Version3.9.1Fixed in Version3.9.3 
Summary0002980: Support transactional sync triggers on platforms where ddl can be transactional
DescriptionPostgres supports DDL transactions.

This will allow triggers to be synchronized on a busy system without the chance for missing an during the drop and re-create of a trigger. The transaction would start with the "drop trigger" and keep the table locked until the "create trigger" completes and commits.
Tagsdialect: postgresql, trigger

Relationships

duplicate of 0003366 closedkstojanovska Support transactional sync triggers 

Activities

chenson

2019-05-14 13:13

administrator   ~0001485

This was implemented by 3366

Issue History

Date Modified Username Field Change
2017-02-03 09:10 chenson New Issue
2017-02-03 09:11 chenson Description Updated View Revisions
2017-03-22 14:44 chenson Status new => acknowledged
2017-05-24 14:49 chenson Target Version 3.9.0 =>
2017-11-17 08:17 chenson Product Version => 3.9.1
2017-11-17 08:17 chenson Target Version => 3.9.1
2019-04-24 10:41 elong Tag Attached: trigger
2019-04-24 10:41 elong Tag Attached: dialect: postgresql
2019-05-14 13:09 elong Description Updated View Revisions
2019-05-14 13:13 chenson Note Added: 0001485
2019-05-14 13:14 chenson Fixed in Version => 3.9.3
2019-05-14 13:15 chenson Assigned To => chenson
2019-05-14 13:15 chenson Status acknowledged => closed
2019-05-14 13:15 chenson Resolution open => duplicate
2019-05-14 13:15 chenson Relationship added duplicate of 0003366