View Issue Details

IDProjectCategoryView StatusLast Update
0002985SymmetricDSBugpublic2017-02-08 08:21
ReportermmichalekAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.8.16 
Target Version3.8.16Fixed in Version3.8.16 
Summary0002985: C Client FileSync raises an error on empty incoming batches
DescriptionFile sync may generate empty batches in cases where a file tracked is no longer available at the time of extraction. For example, if the file tracker runs and tracks file A.pdf, and then that file is renamed to B.pdf, the extraction process will create an empty batch because file A.pdf is no longer available. This behavior is by design, but the C client needs to handle it gracefully.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 177d2bf5

2017-02-07 16:08:56

mmichalek

Details Diff
0002985: C Client FileSync raises an error on empty incoming batches
0002985
add - symmetric-client-clib/inc/transport/http/CurlConfig.h Diff File
mod - symmetric-client-clib/src/service/FileSyncService.c Diff File
mod - symmetric-client-clib/src/service/IncomingBatchService.c Diff File
add - symmetric-client-clib/src/transport/http/CurlConfig.c Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/file/BashFileSyncZipScript.java Diff File

Issue History

Date Modified Username Field Change
2017-02-07 16:05 mmichalek New Issue
2017-02-07 16:05 mmichalek Status new => assigned
2017-02-07 16:05 mmichalek Assigned To => mmichalek
2017-02-07 16:10 mmichalek Status assigned => resolved
2017-02-07 16:10 mmichalek Resolution open => fixed
2017-02-07 16:10 mmichalek Fixed in Version => 3.8.16
2017-02-07 17:00 mmichalek Changeset attached => SymmetricDS 3.8 177d2bf5
2017-02-08 08:21 chenson Status resolved => closed