View Issue Details

IDProjectCategoryView StatusLast Update
0003021SymmetricDS ProBugpublic2017-04-06 09:45
ReportermmichalekAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.8.18 
Target Version3.8.19Fixed in Version3.8.19 
Summary0003021: Clicking OutgoingBatch.batchId may interrupt a batch's extraction
DescriptionIf a batch is current being extracted to a file, and a user clicks the batch ID, a screen appears which is designed to show the extracted batch details. This triggers a process to check if the batch has been extracted, and ends up interrupting the current actual extraction of the batch. This results in this sequence of errors:


2017-03-17 08:53:44,880 ERROR [server] [AppUI] [qtp1847509784-21728] Unable to invoke method click in com.vaadin.shared.ui.button.ButtonServerRpc StackTraceKey.init [RpcInvocationException:3306731978]
com.vaadin.server.ServerRpcManager$RpcInvocationException: Unable to invoke method click in com.vaadin.shared.ui.button.ButtonServerRpc
 at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:160)
 at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:118)
 at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:408)
 at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:273)
 at com.vaadin.server.communication.PushHandler$2.run(PushHandler.java:149)
 at com.vaadin.server.communication.PushHandler.callWithUi(PushHandler.java:243)
 at com.vaadin.server.communication.PushHandler.onMessage(PushHandler.java:503)
 at com.vaadin.server.communication.PushAtmosphereHandler.onMessage(PushAtmosphereHandler.java:88)
 at com.vaadin.server.communication.PushAtmosphereHandler.onRequest(PushAtmosphereHandler.java:78)
 at org.atmosphere.cpr.AsynchronousProcessor.action(AsynchronousProcessor.java:199)
 at org.atmosphere.cpr.AsynchronousProcessor.suspended(AsynchronousProcessor.java:107)
 at org.atmosphere.container.Jetty9AsyncSupportWithWebSocket.service(Jetty9AsyncSupportWithWebSocket.java:180)
 at org.atmosphere.cpr.AtmosphereFramework.doCometSupport(AtmosphereFramework.java:2075)
 at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:571)
 at org.atmosphere.websocket.DefaultWebSocketProcessor$3.run(DefaultWebSocketProcessor.java:333)
 at org.atmosphere.util.VoidExecutorService.execute(VoidExecutorService.java:101)
 at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:328)
 at org.atmosphere.websocket.DefaultWebSocketProcessor.invokeWebSocketProtocol(DefaultWebSocketProcessor.java:425)
 at org.atmosphere.container.Jetty9WebSocketHandler.onWebSocketText(Jetty9WebSocketHandler.java:92)
 at org.eclipse.jetty.websocket.common.events.JettyListenerEventDriver.onTextMessage(JettyListenerEventDriver.java:128)
 at org.eclipse.jetty.websocket.common.message.SimpleTextMessage.messageComplete(SimpleTextMessage.java:69)
 at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.appendMessage(AbstractEventDriver.java:65)
 at org.eclipse.jetty.websocket.common.events.JettyListenerEventDriver.onTextFrame(JettyListenerEventDriver.java:122)
 at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.incomingFrame(AbstractEventDriver.java:161)
 at org.eclipse.jetty.websocket.common.WebSocketSession.incomingFrame(WebSocketSession.java:309)
 at org.eclipse.jetty.websocket.common.extensions.ExtensionStack.incomingFrame(ExtensionStack.java:214)
 at org.eclipse.jetty.websocket.common.Parser.notifyFrame(Parser.java:220)
 at org.eclipse.jetty.websocket.common.Parser.parse(Parser.java:258)
 at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.readParse(AbstractWebSocketConnection.java:632)
 at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onFillable(AbstractWebSocketConnection.java:480)
 at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
 at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
 at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
 at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.reflect.InvocationTargetException
 at sun.reflect.GeneratedMethodAccessor111.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:498)
 at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:158)
 ... 33 more
Caused by: com.vaadin.event.ListenerMethod$MethodException: Invocation of method buttonClick in com.jumpmind.symmetric.console.ui.screen.d.k$14$1 failed.
 at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:528)
 at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:198)
 at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:161)
 at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1008)
 at com.vaadin.ui.Button.fireClick(Button.java:377)
 at com.vaadin.ui.Button$1.click(Button.java:54)
 ... 37 more
Caused by: java.lang.IllegalStateException: There is no content to read. Memory buffer was empty and D:\SymmetricDS\tmp\server\outgoing\551\0010542633.create was not found.
 at org.jumpmind.symmetric.io.stage.StagedResource.getReader(StagedResource.java:194)
 at org.jumpmind.symmetric.io.data.reader.ProtocolDataReader.open(ProtocolDataReader.java:121)
 at com.jumpmind.symmetric.console.ui.common.OutgoingLightDataListTable$OutgoingLightDataQuery.loadBeans(OutgoingLightDataListTable.java:283)
 at org.vaadin.addons.lazyquerycontainer.AbstractBeanQuery.loadItems(AbstractBeanQuery.java:154)
 at org.vaadin.addons.lazyquerycontainer.LazyQueryView.queryItem(LazyQueryView.java:285)
 at org.vaadin.addons.lazyquerycontainer.LazyQueryView.getItem(LazyQueryView.java:262)
 at org.vaadin.addons.lazyquerycontainer.LazyIdList.get(LazyIdList.java:92)
 at org.vaadin.addons.lazyquerycontainer.LazyQueryContainer.firstItemId(LazyQueryContainer.java:276)
 at com.jumpmind.symmetric.console.ui.common.OutgoingLightDataListTable.<init>(OutgoingLightDataListTable.java:110)
 at com.jumpmind.symmetric.console.ui.screen.d.k$d.<init>(OutgoingBatchPanel.java:1365)
 at com.jumpmind.symmetric.console.ui.screen.d.k$14$1.buttonClick(OutgoingBatchPanel.java:300)
 at sun.reflect.GeneratedMethodAccessor70.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:498)
 at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:508)
 ... 42 more
2017-03-17 08:53:44,896 ERROR [server] [DataExtractorService] [qtp1847509784-21671] Failed to extract batch 551-10542633 StackTraceKey.init [RuntimeException:3796782218]
java.lang.RuntimeException: org.jumpmind.exception.IoException: java.io.IOException: Stream closed
 at org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:681)
 at org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:506)
 at org.jumpmind.symmetric.web.PullUriHandler.pull(PullUriHandler.java:130)
 at org.jumpmind.symmetric.web.PullUriHandler.handleWithCompression(PullUriHandler.java:100)
 at org.jumpmind.symmetric.web.AbstractCompressionUriHandler.handle(AbstractCompressionUriHandler.java:84)
 at org.jumpmind.symmetric.web.SymmetricServlet.service(SymmetricServlet.java:114)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
 at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:812)
 at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1669)
 at org.jumpmind.symmetric.web.HttpMethodFilter.doFilter(HttpMethodFilter.java:62)
 at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)
 at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585)
 at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
 at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)
 at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
 at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)
 at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
 at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
 at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)
 at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
 at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
 at org.eclipse.jetty.server.Server.handle(Server.java:499)
 at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)
 at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
 at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
 at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
 at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
 at java.lang.Thread.run(Thread.java:745)
Caused by: org.jumpmind.exception.IoException: java.io.IOException: Stream closed
 at org.jumpmind.symmetric.io.data.writer.StagingDataWriter.print(StagingDataWriter.java:117)
 at org.jumpmind.symmetric.io.data.writer.AbstractProtocolDataWriter.println(AbstractProtocolDataWriter.java:253)
 at org.jumpmind.symmetric.io.data.writer.AbstractProtocolDataWriter.write(AbstractProtocolDataWriter.java:161)
 at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
 at org.jumpmind.symmetric.model.ProcessInfoDataWriter.write(ProcessInfoDataWriter.java:65)
 at org.jumpmind.symmetric.io.data.writer.TransformWriter.write(TransformWriter.java:194)
 at org.jumpmind.symmetric.io.data.DataProcessor.forEachDataInTable(DataProcessor.java:200)
 at org.jumpmind.symmetric.io.data.DataProcessor.forEachTableInBatch(DataProcessor.java:170)
 at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:116)
 at org.jumpmind.symmetric.service.impl.DataExtractorService.extractOutgoingBatch(DataExtractorService.java:848)
 at org.jumpmind.symmetric.service.impl.DataExtractorService$1.call(DataExtractorService.java:602)
 at org.jumpmind.symmetric.service.impl.DataExtractorService$1.call(DataExtractorService.java:573)
 at java.util.concurrent.FutureTask.run(FutureTask.java:266)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
 ... 1 more
Caused by: java.io.IOException: Stream closed
 at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
 at java.io.BufferedWriter.write(BufferedWriter.java:221)
 at java.io.Writer.write(Writer.java:157)
 at java.io.Writer.append(Writer.java:269)
 at org.jumpmind.symmetric.io.data.writer.StagingDataWriter.print(StagingDataWriter.java:114)
 ... 15 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 215f0593

2017-03-23 14:23:24

mmichalek

Details Diff
0003021: Clicking OutgoingBatch.batchId may interrupt a batch's
extraction

0003021
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/common/ParameterConstants.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File
mod - symmetric-core/src/main/resources/symmetric-default.properties Diff File

Issue History

Date Modified Username Field Change
2017-03-20 08:59 mmichalek New Issue
2017-03-20 08:59 mmichalek Status new => assigned
2017-03-20 08:59 mmichalek Assigned To => mmichalek
2017-03-22 08:42 mmichalek Project SymmetricDS => SymmetricDS Pro
2017-03-23 15:00 mmichalek Changeset attached => SymmetricDS 3.8 215f0593
2017-03-26 14:28 chenson Status assigned => resolved
2017-03-26 14:28 chenson Fixed in Version => 3.8.19
2017-03-26 14:28 chenson Resolution open => fixed
2017-04-06 09:45 chenson Status resolved => closed