View Issue Details

IDProjectCategoryView StatusLast Update
0003034SymmetricDSBugpublic2017-04-18 20:00
ReporternuralimcaAssigned Tochenson 
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.8.18 
Target Version3.8.20Fixed in Version3.8.20 
Summary0003034: Failed to extract batch - IllegalStateException: There is no content to read
DescriptionI am getting similar exception like one reported with "https://www.symmetricds.org/issues/view.php?id=2959"

The exception I am getting has different stack trace then the once reporte with issue-2959.

** Here is the stack trace:
2017 03 31 04:05:23#+00#DEBUG#org.jumpmind.symmetric.service.impl.DataExtractorService##anonymous#tnt3_rt-0000-data-extractor-1#na#wb38a11ed#vnsdsload5#web##We have already extracted batch 54. Using the existing extraction: /usr/sap/ljs/temp/tnt3_rt-0000/outgoing/5000/0000000054.done|
2017 03 31 04:05:23#+00#ERROR#org.jumpmind.symmetric.service.impl.DataExtractorService##anonymous#tnt3_rt-0000-push-default-1#na#wb38a11ed#vnsdsload5#web##Failed to extract batch 5000-58java.lang.RuntimeException: java.lang.IllegalStateException: There is no content to read. Memory buffer was empty and /usr/demo/abc/temp/tnt3_rt-0000/outgoing/common/0000000058.create was not found.
    at org.jumpmind.symmetric.service.impl.DataExtractorService.sendOutgoingBatch(DataExtractorService.java:1023)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:665)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:507)
    at org.jumpmind.symmetric.service.impl.PushService.pushToNode(PushService.java:198)
    at org.jumpmind.symmetric.service.impl.PushService.execute(PushService.java:159)
    at org.jumpmind.symmetric.service.impl.NodeCommunicationService$1.run(NodeCommunicationService.java:499)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:807)
Caused by: java.lang.IllegalStateException: There is no content to read. Memory buffer was empty and /usr/demo/abc/temp/tnt3_rt-0000/outgoing/common/0000000058.create was not found.
    at org.jumpmind.symmetric.io.stage.StagedResource.getReader(StagedResource.java:174)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.sendOutgoingBatch(DataExtractorService.java:1016)
    ... 8 common frames omitted

** Stack Trace End **

This issue is happening during initial load. I have some 20k records to be copied during initial load and at the same time running load adds about 5 records per seconds. Once this issue happened, the batch for which this issue happen get Error status in sym_outgoing_batch table and my whole replication operation stuck.

Some may be relevant properties:
stream.to.file.enabled=true
stream.to.file.threshold.bytes=32767
stream.to.file.ttl.ms=5000
stream.to.file.purge.on.ttl.enabled=true

Version: Symmetric DS 3.8.18

Cheers,
Nurali
Steps To ReproduceThis issue is happening during initial load. I have some 20k records to be copied during initial load and at the same time running load adds about 5 records per seconds.
TagsNo tags attached.

Activities

chenson

2017-03-31 16:14

administrator   ~0000992

In general, I think those are bad settings to use.

If you put a much longer ttl does it work?

Related Changesets

SymmetricDS: 3.8 7a3602cf

2017-04-18 10:10:42

chenson42

Details Diff
0003034: Failed to extract batch - IllegalStateException: There is no
content to read

0003034
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/StagingDataWriter.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File

SymmetricDS: 3.8 44a5edb7

2017-04-18 13:51:45

chenson42

Details Diff
0003034: Failed to extract batch - IllegalStateException: There is no
content to read

0003034
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File

SymmetricDS: 3.8 1c2bf422

2017-04-18 19:52:23

chenson42

Details Diff
0003034: Failed to extract batch - IllegalStateException: There is no
content to read

0003034
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File

Issue History

Date Modified Username Field Change
2017-03-31 01:55 nuralimca New Issue
2017-03-31 16:14 chenson Note Added: 0000992
2017-04-18 10:11 chenson Status new => resolved
2017-04-18 10:11 chenson Fixed in Version => 3.8.20
2017-04-18 10:11 chenson Resolution open => fixed
2017-04-18 10:11 chenson Assigned To => chenson
2017-04-18 10:11 chenson Target Version => 3.8.20
2017-04-18 11:00 chenson42 Changeset attached => SymmetricDS 3.8 7a3602cf
2017-04-18 14:00 chenson42 Changeset attached => SymmetricDS 3.8 44a5edb7
2017-04-18 15:44 chenson Status resolved => closed
2017-04-18 20:00 chenson42 Changeset attached => SymmetricDS 3.8 1c2bf422