View Issue Details

IDProjectCategoryView StatusLast Update
0003058SymmetricDSBugpublic2017-04-18 15:44
ReportersbailliezAssigned Tochenson 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version3.8.19 
Target Version3.8.20Fixed in Version3.8.20 
Summary0003058: Every sql error causes "There is no content to read. Memory buffer was empty and <file> was not found"
DescriptionAs soon as an error occurs in a sql statement, batches seem to be lost and fail forever. I have to get rid of them and mark as ok. This seems new as part of 3.8.19 and never seen this in 3.8.11 or before.

For example after doing a send-schema where a domain/type was missing in the target database (postgresql)

2017-04-17 19:40:45,718 ERROR [xxxxxx-000] [DataExtractorService] [qtp1701436909-39] Failed to extract batch 001-670 StackTraceKey.init [IllegalStateException:4280487409]
java.lang.IllegalStateException: There is no content to read. Memory buffer was empty and /web/xxx/symmetric-server-3.8.19/tmp/xxxxxx-000/outgoing/001/0000000670.create was not found.
    at org.jumpmind.symmetric.io.stage.StagedResource.getReader(StagedResource.java:176)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.transferFromStaging(DataExtractorService.java:1081)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.sendOutgoingBatch(DataExtractorService.java:1042)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:671)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:513)
    at org.jumpmind.symmetric.web.PullUriHandler.pull(PullUriHandler.java:130)
    at org.jumpmind.symmetric.web.PullUriHandler.handleWithCompression(PullUriHandler.java:100)
    at org.jumpmind.symmetric.web.AbstractCompressionUriHandler.handle(AbstractCompressionUriHandler.java:84)
    at org.jumpmind.symmetric.web.SymmetricServlet.service(SymmetricServlet.java:114)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:812)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1669)
    at org.jumpmind.symmetric.web.HttpMethodFilter.doFilter(HttpMethodFilter.java:62)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
    at org.eclipse.jetty.server.Server.handle(Server.java:499)
    at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
    at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
    at java.lang.Thread.run(Thread.java:745)

After that error, it continuously log:

2017-04-17 19:40:55,684 ERROR [xxxx-000] [DataExtractorService] [qtp1701436909-36] Failed to extract batch 001-670 StackTraceKey [IllegalStateException:4280487409]
TagsNo tags attached.

Activities

chenson

2017-04-17 15:56

administrator   ~0001012

What all parameters do you have set?

sbailliez

2017-04-17 16:16

reporter   ~0001013

source is

engine.name=source-000
db.driver=org.postgresql.Driver
db.url=jdbc:postgresql://foobar/foo?protocolVersion=2&stringtype=unspecified
db.user=foo
db.password=foo
registration.url=http://localhost:31415/sync/source-000
sync.url=http://localhost:31415/sync/source-000
group.id=source
external.id=000
job.purge.period.time.ms=7200000
job.routing.period.time.ms=5000
job.push.period.time.ms=10000
job.pull.period.time.ms=10000
initial.load.create.first=true

destination is

engine.name=target-001
db.driver=org.postgresql.Driver
db.url=jdbc:postgresql://foobar/reporting?protocolVersion=2&stringtype=unspecified
db.user=foo
db.password=foo
registration.url=http://localhost:31415/sync/source-000
sync.url=http://localhost:8080/sync/target-001
group.id=target
external.id=001
job.routing.period.time.ms=5000
job.push.period.time.ms=10000
job.pull.period.time.ms=10000
auto.config.database=true

chenson

2017-04-17 16:22

administrator   ~0001014

Nothing looks unusual there. Do you have parameters set in sym_parameter? Do you have an old version of conf/symmetric.properties?

If conf/symmetric.properties exists, can you remove it and see if you can reproduce?

sbailliez

2017-04-17 17:04

reporter   ~0001015

mmm yeah symmetric.properties was deployed as a generic configuration for all releases, let me delete as you suggested and see how I can possibly reproduce

sbailliez

2017-04-17 18:22

reporter   ~0001016

That seems to work better, I cannot reproduce at this time. Any idea what setting could be responsible for this ?

chenson

2017-04-18 08:10

administrator   ~0001017

When stream.to.file.threshold.bytes is set to a non-zero value and a batch fails it looks like you get into this state.

chenson

2017-04-18 10:12

administrator   ~0001018

I checked in a fix under this issue: 3034

Issue History

Date Modified Username Field Change
2017-04-17 15:52 sbailliez New Issue
2017-04-17 15:56 chenson Note Added: 0001012
2017-04-17 16:16 sbailliez Note Added: 0001013
2017-04-17 16:22 chenson Note Added: 0001014
2017-04-17 17:04 sbailliez Note Added: 0001015
2017-04-17 18:22 sbailliez Note Added: 0001016
2017-04-18 08:10 chenson Note Added: 0001017
2017-04-18 10:12 chenson Note Added: 0001018
2017-04-18 10:12 chenson Fixed in Version => 3.8.20
2017-04-18 10:12 chenson Target Version => 3.8.20
2017-04-18 10:12 chenson Status new => resolved
2017-04-18 10:12 chenson Resolution open => fixed
2017-04-18 10:12 chenson Assigned To => chenson
2017-04-18 15:44 chenson Status resolved => closed