View Issue Details

IDProjectCategoryView StatusLast Update
0003060SymmetricDSBugpublic2018-02-14 15:08
ReportermmichalekAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.9.0 
Target Version3.9.0Fixed in Version3.9.0 
Summary0003060: Data generated by a transform isn't visible to later transforms (when using multiple load transforms on one table)
DescriptionFor example: say you have one source table, transaction. On transaction, say you have two load transforms, one called trans_header and another called trans_details (in that order). If the trans_details transform tried to select any data from trans_header (via a lookup column transform), the data will not be found and will come back null.

The reason for this is that TransformWriter processes all the transforms for one CSV row as a first phase, and then, as a second phase, it writes the results of those transforms to the database. The change for this issue will be to process and write the data for each transform on a table in a single phase, so that each transform will have database visibility to the data generated by previous transforms on that row.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.9 bd4549fc

2017-04-18 13:32:59

mmichalek

Details Diff
0003060: Data generated by a transform isn't visible to later transforms
(when using multiple load transforms on one table)

0003060
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/writer/TransformWriter.java Diff File

Issue History

Date Modified Username Field Change
2017-04-18 13:26 mmichalek New Issue
2017-04-18 13:26 mmichalek Status new => assigned
2017-04-18 13:26 mmichalek Assigned To => mmichalek
2017-05-24 14:57 mmichalek Status assigned => resolved
2017-05-24 14:57 mmichalek Resolution open => fixed
2017-05-24 14:57 mmichalek Fixed in Version => 3.9.0
2017-12-15 16:21 mmichalek Status resolved => closed
2018-02-14 15:08 mmichalek Changeset attached => SymmetricDS 3.9 bd4549fc