View Issue Details

IDProjectCategoryView StatusLast Update
0003078SymmetricDSBugpublic2019-08-26 08:45
ReportersidAssigned To 
Priorityhigh 
Status closedResolutionopen 
Product Version3.8.21 
Target VersionFixed in Version 
Summary0003078: Unable to complete all the DDL scripts on DB2 10.5
DescriptionTrying to start SymmetricDS for the first time with one master node and after creating the tables and environment variables it fails on creating all DB objects

I am guessing there DB2 version could be the problem, since as per the docs SymmetricDS has been tested on DB 9.

OS: AIX
DB: DB2 v10.5

Error:
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_CONFLICT"
    ADD CONSTRAINT "SYM_FK_CF_2_GRP_LNK" FOREIGN KEY ("SOURCE_NODE_GROUP_ID", "T
ARGET_NODE_GROUP_ID") REFERENCES "SYM_NODE_GROUP_LINK" ("SOURCE_NODE_GROUP_ID",
"TARGET_NODE_GROUP_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_FILE_TRIGGE
R_ROUTER"
    ADD CONSTRAINT "SYM_FK_FTR_2_FTRG" FOREIGN KEY ("TRIGGER_ID") REFERENCES "SY
M_FILE_TRIGGER" ("TRIGGER_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_FILE_TRIGGE
R_ROUTER"
    ADD CONSTRAINT "SYM_FK_FTR_2_RTR" FOREIGN KEY ("ROUTER_ID") REFERENCES "SYM_
ROUTER" ("ROUTER_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_GROUPLET_LI
NK"
    ADD CONSTRAINT "SYM_FK_GPLTLNK_2_GPLT" FOREIGN KEY ("GROUPLET_ID") REFERENCE
S "SYM_GROUPLET" ("GROUPLET_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_NODE_GROUP_
LINK"
    ADD CONSTRAINT "SYM_FK_LNK_2_GRP_SRC" FOREIGN KEY ("SOURCE_NODE_GROUP_ID") R
EFERENCES "SYM_NODE_GROUP" ("NODE_GROUP_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_NODE_GROUP_
LINK"
    ADD CONSTRAINT "SYM_FK_LNK_2_GRP_TGT" FOREIGN KEY ("TARGET_NODE_GROUP_ID") R
EFERENCES "SYM_NODE_GROUP" ("NODE_GROUP_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_NODE_IDENTI
TY"
    ADD CONSTRAINT "SYM_FK_IDENT_2_NODE" FOREIGN KEY ("NODE_ID") REFERENCES "SYM
_NODE" ("NODE_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_NODE_SECURI
TY"
    ADD CONSTRAINT "SYM_FK_SEC_2_NODE" FOREIGN KEY ("NODE_ID") REFERENCES "SYM_N
ODE" ("NODE_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_ROUTER"
    ADD CONSTRAINT "SYM_FK_RT_2_GRP_LNK" FOREIGN KEY ("SOURCE_NODE_GROUP_ID", "T
ARGET_NODE_GROUP_ID") REFERENCES "SYM_NODE_GROUP_LINK" ("SOURCE_NODE_GROUP_ID",
"TARGET_NODE_GROUP_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_TRANSFORM_T
ABLE"
    ADD CONSTRAINT "SYM_FK_TT_2_GRP_LNK" FOREIGN KEY ("SOURCE_NODE_GROUP_ID", "T
ARGET_NODE_GROUP_ID") REFERENCES "SYM_NODE_GROUP_LINK" ("SOURCE_NODE_GROUP_ID",
"TARGET_NODE_GROUP_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_TRIGGER"
    ADD CONSTRAINT "SYM_FK_TRG_2_CHNL" FOREIGN KEY ("CHANNEL_ID") REFERENCES "SY
M_CHANNEL" ("CHANNEL_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_TRIGGER"
    ADD CONSTRAINT "SYM_FK_TRG_2_RLD_CHNL" FOREIGN KEY ("RELOAD_CHANNEL_ID") REF
ERENCES "SYM_CHANNEL" ("CHANNEL_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_TRIGGER_ROU
TER"
    ADD CONSTRAINT "SYM_FK_TR_2_TRG" FOREIGN KEY ("TRIGGER_ID") REFERENCES "SYM_
TRIGGER" ("TRIGGER_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_TRIGGER_ROU
TER"
    ADD CONSTRAINT "SYM_FK_TR_2_RTR" FOREIGN KEY ("ROUTER_ID") REFERENCES "SYM_R
OUTER" ("ROUTER_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_TRIGGER_ROU
TER_GROUPLET"
    ADD CONSTRAINT "SYM_FK_TRGPLT_2_GPLT" FOREIGN KEY ("GROUPLET_ID") REFERENCES
 "SYM_GROUPLET" ("GROUPLET_ID")
[adams-node] - Db2v9SymmetricDialect - DDL applied: ALTER TABLE "SYM_TRIGGER_ROU
TER_GROUPLET"
    ADD CONSTRAINT "SYM_FK_TRGPLT_2_TR" FOREIGN KEY ("TRIGGER_ID", "ROUTER_ID")
REFERENCES "SYM_TRIGGER_ROUTER" ("TRIGGER_ID", "ROUTER_ID")
[adams-node] - Db2v9SymmetricDialect - Done with auto update of SymmetricDS tabl
es
[adams-node] - Db2v9SymmetricDialect - Resetting auto increment columns for sym_
data
[adams-node] - Db2v9SymmetricDialect - Creating environment variables sym_sync_t
riggers_disabled and sym_sync_node_disabled
[adams-node] - AbstractSymmetricEngine - An error occurred while starting Symmet
ricDS
org.jumpmind.db.sql.SqlException: DB2 SQL Error: SQLCODE=-601, SQLSTATE=42710, S
QLERRMC=DEVELOPMENT.SYM_SYNC_NODE_DISABLED;VARIABLE, DRIVER=3.57.82
        at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate
.java:300)
        at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate
.java:291)
        at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:493)

        at org.jumpmind.db.sql.JdbcSqlTemplate.update(JdbcSqlTemplate.java:342)
        at org.jumpmind.db.sql.AbstractSqlTemplate.update(AbstractSqlTemplate.ja
va:224)
        at org.jumpmind.symmetric.db.db2.Db2SymmetricDialect.createRequiredDatab
aseObjects(Db2SymmetricDialect.java:92)
        at org.jumpmind.symmetric.db.db2.Db2v9SymmetricDialect.createRequiredDat
abaseObjects(Db2v9SymmetricDialect.java:71)
        at org.jumpmind.symmetric.db.AbstractSymmetricDialect.initTablesAndDatab
aseObjects(AbstractSymmetricDialect.java:157)
        at org.jumpmind.symmetric.AbstractSymmetricEngine.setupDatabase(Abstract
SymmetricEngine.java:449)
        at org.jumpmind.symmetric.AbstractSymmetricEngine.setup(AbstractSymmetri
cEngine.java:423)
        at org.jumpmind.symmetric.AbstractSymmetricEngine.start(AbstractSymmetri
cEngine.java:580)
        at org.jumpmind.symmetric.AbstractSymmetricEngine.start(AbstractSymmetri
cEngine.java:571)
        at org.jumpmind.symmetric.ClientSymmetricEngine.start(ClientSymmetricEng
ine.java:244)
        at org.jumpmind.symmetric.web.SymmetricEngineHolder$EngineStarter.run(Sy
mmetricEngineHolder.java:478)
Caused by: com.ibm.db2.jcc.am.io: DB2 SQL Error: SQLCODE=-601, SQLSTATE=42710, S
QLERRMC=DEVELOPMENT.SYM_SYNC_NODE_DISABLED;VARIABLE, DRIVER=3.57.82
        at com.ibm.db2.jcc.am.bd.a(bd.java:676)
        at com.ibm.db2.jcc.am.bd.a(bd.java:60)
        at com.ibm.db2.jcc.am.bd.a(bd.java:127)
        at com.ibm.db2.jcc.am.km.b(km.java:2164)
        at com.ibm.db2.jcc.am.km.c(km.java:2147)
        at com.ibm.db2.jcc.t4.db.k(db.java:354)
        at com.ibm.db2.jcc.t4.db.a(db.java:60)
        at com.ibm.db2.jcc.t4.t.a(t.java:50)
        at com.ibm.db2.jcc.t4.tb.b(tb.java:218)
        at com.ibm.db2.jcc.am.lm.ec(lm.java:2692)
        at com.ibm.db2.jcc.am.lm.b(lm.java:3552)
        at com.ibm.db2.jcc.am.lm.Yb(lm.java:2130)
        at com.ibm.db2.jcc.am.lm.execute(lm.java:2114)
        at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(Delegatin
gPreparedStatement.java:172)
        at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(Delegatin
gPreparedStatement.java:172)
        at org.jumpmind.db.sql.JdbcSqlTemplate$5.execute(JdbcSqlTemplate.java:37
4)
        at org.jumpmind.db.sql.JdbcSqlTemplate$5.execute(JdbcSqlTemplate.java:34
2)
        at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:491)

        ... 11 more
[adams-node] - AbstractSymmetricEngine - Stopping SymmetricDS externalId=000 ver
sion=3.8.21 database=DB2/AIX64
[adams-node] - AbstractSymmetricEngine - SymmetricDS: type=server, name=adams-no
de, version=3.8.21, groupId=adams-server, externalId=000, databaseName=DB2/AIX64
, databaseVersion=10.5, driverName=IBM DB2 JDBC Universal Driver Architecture, d
riverVersion=3.57.82

Steps To Reproduce1. Create a sample master node engine file pointing it to a DB2 v10.5 on AIX (OS shouldn't be a problem here)
2. Run sym.bat
Tagsdialect: db2, install

Activities

hanes

2018-10-17 16:24

developer   ~0001292

I believe the 3.9 version of SymmetricDS supports DB2 10. Can you test with 3.9?

admin

2019-08-26 08:45

administrator   ~0001584

Auto closing all issues waiting for feedback after 4 months. We don't have enough information to take any action.

Issue History

Date Modified Username Field Change
2017-04-27 13:33 sid New Issue
2018-10-17 16:24 hanes Status new => feedback
2018-10-17 16:24 hanes Note Added: 0001292
2019-04-24 10:57 elong Tag Attached: dialect: db2
2019-04-24 10:57 elong Tag Attached: install
2019-08-26 08:45 admin Note Added: 0001584
2019-08-26 08:45 admin Status feedback => closed