View Issue Details

IDProjectCategoryView StatusLast Update
0003094SymmetricDSBugpublic2017-05-12 10:21
ReporterelongAssigned Toelong 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.8.17 
Target Version3.8.24Fixed in Version3.8.24 
Summary0003094: Status of batches set to resend when error on channel
DescriptionWhen a batch error occurs, other batches being sent get their status set to "RS" for resend. The log on the target node will show:

The batch XX was missing in staging. Setting status to resend

Instead, batches should be retried from staging, which is more efficient.

Regression caused by issue 0002995.
TagsNo tags attached.

Relationships

related to 0002995 closedchenson IllegalStateException - no content found after fixing transform 

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 5c879417

2017-05-05 09:18:22

admin

Details Diff
0003094: Status of batches set to resend when error on channel
0003094
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataLoaderService.java Diff File

Issue History

Date Modified Username Field Change
2017-05-05 09:12 elong New Issue
2017-05-05 09:12 elong Status new => assigned
2017-05-05 09:12 elong Assigned To => elong
2017-05-05 09:17 elong Relationship added related to 0002995
2017-05-05 09:17 elong Product Version 3.8.0 => 3.8.17
2017-05-05 09:17 elong Description Updated View Revisions
2017-05-05 14:00 admin Changeset attached => SymmetricDS 3.8 5c879417
2017-05-05 14:37 elong Status assigned => resolved
2017-05-05 14:37 elong Fixed in Version => 3.8.24
2017-05-05 14:37 elong Resolution open => fixed
2017-05-12 10:21 chenson Status resolved => closed