View Issue Details

IDProjectCategoryView StatusLast Update
0003136SymmetricDS ProBugpublic2017-06-05 09:09
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.24 
Target Version3.8.25Fixed in Version3.8.25 
Summary0003136: The load summary page is slow because of unused joins to sym_data
DescriptionThe load summary page is slow because of unused joins to sym_data.


2017-06-02 13:23:57,420 INFO [gui] [JdbcSqlTemplate] [http-nio-8080-exec-6] Long Running: (27793ms.) select b.load_id, b.node_id, b.status, b.create_by, max(error_flag) as error_flag, count(*) as cnt, min(b.create_time) as create_time, max(b.last_update_time) as last_update_time, min(b.batch_id) as current_batch_id, min(b.data_event_count) as current_data_event_count, b.channel_id from sym_outgoing_batch b inner join sym_data_event e on b.batch_id=e.batch_id inner join sym_data d on d.data_id=e.data_id join sym_channel c on c.channel_id = b.channel_id where c.reload_flag = 1 and b.load_id > 0 group by b.load_id, b.node_id, b.status, b.channel_id, b.create_by order by b.load_id desc
2017-06-02 13:24:22,558 INFO [gui] [JdbcSqlTemplate] [http-nio-8080-exec-6] Long Running: (25131ms.) select b.load_id, b.node_id, b.status, b.create_by, max(error_flag) as error_flag, count(*) as cnt, min(b.create_time) as create_time, max(b.last_update_time) as last_update_time, min(b.batch_id) as current_batch_id, min(b.data_event_count) as current_data_event_count, b.channel_id from sym_outgoing_batch b inner join sym_data_event e on b.batch_id=e.batch_id inner join sym_data d on d.data_id=e.data_id join sym_channel c on c.channel_id = b.channel_id where c.reload_flag = 1 and b.load_id > 0 group by b.load_id, b.node_id, b.status, b.channel_id, b.create_by order by b.load_id desc
2017-06-02 13:24:47,687 INFO [gui] [JdbcSqlTemplate] [http-nio-8080-exec-6] Long Running: (25126ms.) select b.load_id, b.node_id, b.status, b.create_by, max(error_flag) as error_flag, count(*) as cnt, min(b.create_time) as create_time, max(b.last_update_time) as last_update_time, min(b.batch_id) as current_batch_id, min(b.data_event_count) as current_data_event_count, b.channel_id from sym_outgoing_batch b inner join sym_data_event e on b.batch_id=e.batch_id inner join sym_data d on d.data_id=e.data_id join sym_channel c on c.channel_id = b.channel_id where c.reload_flag = 1 and b.load_id > 0 group by b.load_id, b.node_id, b.status, b.channel_id, b.create_by order by b.load_id desc
2017-06-02 13:25:16,283 INFO [gui] [JdbcSqlTemplate] [http-nio-8080-exec-6] Long Running: (28592ms.) select b.load_id, b.node_id, b.status, b.create_by, max(error_flag) as error_flag, count(*) as cnt, min(b.create_time) as create_time, max(b.last_update_time) as last_update_time, min(b.batch_id) as current_batch_id, min(b.data_event_count) as current_data_event_count, b.channel_id from sym_outgoing_batch b inner join sym_data_event e on b.batch_id=e.batch_id inner join sym_data d on d.data_id=e.data_id join sym_channel c on c.channel_id = b.channel_id where c.reload_flag = 1 and b.load_id > 0 group by b.load_id, b.node_id, b.status, b.channel_id, b.create_by order by b.load_id desc
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 b1c19a3a

2017-06-02 13:42:01

chenson42

Details Diff
0003136: The load summary page is slow because of unused joins to
sym_data

0003136
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/OutgoingBatchServiceSqlMap.java Diff File

Issue History

Date Modified Username Field Change
2017-06-02 13:41 chenson New Issue
2017-06-02 13:41 chenson Status new => assigned
2017-06-02 13:41 chenson Assigned To => chenson
2017-06-02 13:42 chenson Status assigned => resolved
2017-06-02 13:42 chenson Fixed in Version => 3.8.25
2017-06-02 13:42 chenson Resolution open => fixed
2017-06-02 14:00 chenson42 Changeset attached => SymmetricDS 3.8 b1c19a3a
2017-06-05 09:09 chenson Status resolved => closed