View Issue Details

IDProjectCategoryView StatusLast Update
0003152SymmetricDSBugpublic2017-07-07 14:13
ReportersudeenAssigned Tojosh-a-hicks 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version3.8.24 
Target Version3.8.27Fixed in Version3.8.27 
Summary0003152: org.jumpmind.db.sql.SqlException: JZ0NK: Generated keys are not available because either the Statement.NO_GENERATED_KEYS was use
DescriptionSybase : 'Adaptive Server Enterprise', version '16', protocol 'sybase'
SymmetricDS : 3.8.24

2017-06-09 13:46:07,092 INFO [cord1_ordering_cur_edb] [AbstractSymmetricEngine] [symmetric-engine-startup-0] SymmetricDS: type=server, name=cord1_ordering_cur_edb, version=3.8.24, groupId=cord1_ordering_cur_edb, externalId=003, databaseName=Adaptive Server Enterprise, databaseVersion=16.0, driverName=jConnect (TM) for JDBC (TM), driverVersion=jConnect (TM) for JDBC(TM)/6.05(Build 26023)/P/EBF14466/JDK14/Thu Mar 15 1:05:45 2007
2017-06-09 13:46:10,385 INFO [cord1_ordering_cur_edb] [NodeCommunicationService] [cord1_ordering_cur_edb-job-2] push will use 10 threads
2017-06-09 13:46:10,509 INFO [cord1_ordering_cur_edb] [NodeCommunicationService] [cord1_ordering_cur_edb-job-3] pull will use 10 threads
2017-06-09 13:46:11,027 INFO [cord1_ordering_cur_edb] [DataService] [cord1_ordering_cur_edb-job-1] Queueing up an initial load to node 004
2017-06-09 13:46:15,265 INFO [cord1_ordering_cur_edb] [PullService] [cord1_ordering_cur_edb-pull-default-1] Pull data received from cord1_ordering_cur_pg:004:004 on channel thread default. 1 rows and 1 batches were processed
2017-06-09 13:46:37,263 ERROR [cord1_ordering_cur_edb] [RouterService] [cord1_ordering_cur_edb-job-1] StackTraceKey.init [SqlException:1103203849]
org.jumpmind.db.sql.SqlException: JZ0NK: Generated keys are not available because either the Statement.NO_GENERATED_KEYS was used or no keys were automatically generated.
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:300)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:291)
    at org.jumpmind.db.sql.JdbcSqlTransaction.insertWithGeneratedKey(JdbcSqlTransaction.java:504)
    at org.jumpmind.symmetric.service.impl.DataService.insertData(DataService.java:1193)
    at org.jumpmind.symmetric.service.impl.DataService.insertDataAndDataEventAndOutgoingBatch(DataService.java:1312)
    at org.jumpmind.symmetric.service.impl.DataService.insertNodeSecurityUpdate(DataService.java:1379)
    at org.jumpmind.symmetric.service.impl.DataService.insertSqlEventsPriorToReload(DataService.java:608)
    at org.jumpmind.symmetric.service.impl.DataService.insertReloadEvents(DataService.java:435)
    at org.jumpmind.symmetric.service.impl.DataService.insertReloadEvents(DataService.java:349)
    at org.jumpmind.symmetric.service.impl.RouterService.insertInitialLoadEvents(RouterService.java:263)
    at org.jumpmind.symmetric.service.impl.RouterService.routeData(RouterService.java:198)
    at org.jumpmind.symmetric.job.RouterJob.doJob(RouterJob.java:50)
    at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:175)
    at org.jumpmind.symmetric.job.AbstractJob.run(AbstractJob.java:219)
    at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:54)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:748)
Caused by: java.sql.SQLException: JZ0NK: Generated keys are not available because either the Statement.NO_GENERATED_KEYS was used or no keys were automatically generated.
    at com.sybase.jdbc3.jdbc.ErrorMessage.raiseError(Unknown Source)
    at com.sybase.jdbc3.jdbc.SybStatement.getGeneratedKeys(Unknown Source)
    at org.apache.commons.dbcp.DelegatingStatement.getGeneratedKeys(DelegatingStatement.java:315)
    at org.apache.commons.dbcp.DelegatingStatement.getGeneratedKeys(DelegatingStatement.java:315)
    at org.jumpmind.db.sql.JdbcSqlTemplate.insertWithGeneratedKey(JdbcSqlTemplate.java:833)
    at org.jumpmind.db.sql.JdbcSqlTransaction.insertWithGeneratedKey(JdbcSqlTransaction.java:501)
    ... 19 more
Additional InformationIts been a blocker for me..since i am not able to proceed with this error. Thanks in advance
Sudeen
TagsNo tags attached.

Activities

sudeen

2017-06-09 17:52

reporter   ~0001055

engine.name=cord1_ordering_cur_edb

db.driver=com.sybase.jdbc3.jdbc.SybDriver

# The JDBC URL used to connect to the database
db.url=jdbc:sybase:Tds:psplsyb01p.fleet.ad:2050/cord1_ordering_cur

# The user to login as who can create and update tables
db.user=gen_sym_user

# The password for the user to login as
db.password=xxxxxxxx

db.pool.initial.size=5
db.pool.max.active=10

# The HTTP URL of the root node to contact for registration
registration.url=
#registration.url=http://localhost:8080/sync/cord1_ordering_cur_edb

sync.url=http://localhost:8080/sync/cord1_ordering_cur_edb
# Do not change these for running the demo
group.id=cord1_ordering_cur_edb
external.id=003

# This is how often the routing job will be run in milliseconds
job.routing.period.time.ms=5000
# This is how often the push job will be run.
job.push.period.time.ms=10000
# This is how often the pull job will be run.
job.pull.period.time.ms=10000

#when symmetric starts up it will try to create the necessary tables.
#auto.config.database=true
#auto.sync.configuration=true

josh-a-hicks

2017-06-23 08:47

developer   ~0001056

Sudeen

Here is a patch to resolve this issue it will be part of the next release 3.8.27

https://support.jumpmind.com/downloads/symmetricds/patches/3.8/patch-0003152.jar

Related Changesets

SymmetricDS: 3.8 9f6eee41

2017-06-23 08:44:48

josh-a-hicks

Details Diff
0003152: org.jumpmind.db.sql.SqlException: JZ0NK: Generated keys are not
available because either the Statement.NO_GENERATED_KEYS was use

0003152
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/sybase/SybaseJdbcSqlTemplate.java Diff File

SymmetricDS: 3.8 d1b5798d

2017-07-05 17:15:58

chenson42

Details Diff
0003152: org.jumpmind.db.sql.SqlException: JZ0NK: Generated keys are not
available because either the Statement.NO_GENERATED_KEYS was use

0003152
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/sybase/SybaseJdbcSqlTemplate.java Diff File

Issue History

Date Modified Username Field Change
2017-06-09 16:19 sudeen New Issue
2017-06-09 17:52 sudeen Note Added: 0001055
2017-06-23 08:47 josh-a-hicks Note Added: 0001056
2017-06-23 08:48 josh-a-hicks Assigned To => josh-a-hicks
2017-06-23 08:48 josh-a-hicks Status new => assigned
2017-06-23 08:48 josh-a-hicks Status assigned => resolved
2017-06-23 08:48 josh-a-hicks Fixed in Version => 3.8.27
2017-06-23 08:48 josh-a-hicks Resolution open => fixed
2017-06-23 09:00 josh-a-hicks Changeset attached => SymmetricDS 3.8 9f6eee41
2017-07-05 17:05 chenson Target Version => 3.8.27
2017-07-05 18:00 chenson42 Changeset attached => SymmetricDS 3.8 d1b5798d
2017-07-07 14:13 chenson Status resolved => closed