View Issue Details

IDProjectCategoryView StatusLast Update
0003175SymmetricDS ProBugpublic2019-11-29 12:00
Reportergilles.riandAssigned Topmarzullo 
Prioritynormal 
Status closedResolutionduplicate 
Product Version3.8.26 
Target VersionFixed in Version 
Summary0003175: SQL Explorer with Interbase XE gets unsupported JDBC method error
Description2017-06-30 16:12:47,933 ERROR [server] [DatabaseInfoPanel] [qtp198761306-233] StackTraceKey.init [DriverNotCapableException:3593356605]
interbase.interclient.DriverNotCapableException: [interclient] Unsupported feature: Using a JDBC method which is not yet supported.
See API reference for exception interbase.interclient.DriverNotCapableException
    at interbase.interclient.DatabaseMetaData.getClientInfoProperties(Unknown Source)
    at org.apache.commons.dbcp.DelegatingDatabaseMetaData.getClientInfoProperties(DelegatingDatabaseMetaData.java:1171)
    at org.jumpmind.vaadin.ui.sqlexplorer.DatabaseInfoPanel.<init>(DatabaseInfoPanel.java:69)
    at org.jumpmind.vaadin.ui.sqlexplorer.SqlExplorer$8.valueChange(SqlExplorer.java:457)
    at sun.reflect.GeneratedMethodAccessor54.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:508)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:198)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:161)
    at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1008)
    at com.vaadin.ui.AbstractField.fireValueChange(AbstractField.java:1159)
    at com.vaadin.ui.AbstractField.setValue(AbstractField.java:570)
    at com.vaadin.ui.AbstractSelect.setValue(AbstractSelect.java:727)
    at com.vaadin.ui.AbstractField.setValue(AbstractField.java:468)
    at com.vaadin.ui.AbstractSelect.setValue(AbstractSelect.java:694)
    at org.jumpmind.vaadin.ui.sqlexplorer.DbTree.refresh(DbTree.java:125)
    at org.jumpmind.vaadin.ui.sqlexplorer.SqlExplorer.refresh(SqlExplorer.java:663)
    at com.jumpmind.symmetric.console.ui.screen.e.onRefresh(ExploreScreen.java:60)
    at com.jumpmind.symmetric.console.ui.b$3.run(MainWindow.java:398)
    at com.jumpmind.symmetric.console.ui.b.goToView(MainWindow.java:410)
    at com.jumpmind.symmetric.console.ui.b$a.menuSelected(MainWindow.java:530)
    at com.vaadin.ui.MenuBar.changeVariables(MenuBar.java:199)
    at com.vaadin.server.communication.ServerRpcHandler.changeVariables(ServerRpcHandler.java:603)
    at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:422)
    at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:273)
    at com.vaadin.server.communication.PushHandler$2.run(PushHandler.java:149)
    at com.vaadin.server.communication.PushHandler.callWithUi(PushHandler.java:243)
    at com.vaadin.server.communication.PushHandler.onMessage(PushHandler.java:503)
    at com.vaadin.server.communication.PushAtmosphereHandler.onMessage(PushAtmosphereHandler.java:88)
    at com.vaadin.server.communication.PushAtmosphereHandler.onRequest(PushAtmosphereHandler.java:78)
    at org.atmosphere.cpr.AsynchronousProcessor.action(AsynchronousProcessor.java:199)
    at org.atmosphere.cpr.AsynchronousProcessor.suspended(AsynchronousProcessor.java:107)
    at org.atmosphere.container.Jetty9AsyncSupportWithWebSocket.service(Jetty9AsyncSupportWithWebSocket.java:180)
    at org.atmosphere.cpr.AtmosphereFramework.doCometSupport(AtmosphereFramework.java:2075)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:571)
    at org.atmosphere.websocket.DefaultWebSocketProcessor$3.run(DefaultWebSocketProcessor.java:333)
    at org.atmosphere.util.VoidExecutorService.execute(VoidExecutorService.java:101)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:328)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.invokeWebSocketProtocol(DefaultWebSocketProcessor.java:425)
    at org.atmosphere.container.Jetty9WebSocketHandler.onWebSocketText(Jetty9WebSocketHandler.java:92)
    at org.eclipse.jetty.websocket.common.events.JettyListenerEventDriver.onTextMessage(JettyListenerEventDriver.java:128)
    at org.eclipse.jetty.websocket.common.message.SimpleTextMessage.messageComplete(SimpleTextMessage.java:69)
    at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.appendMessage(AbstractEventDriver.java:65)
    at org.eclipse.jetty.websocket.common.events.JettyListenerEventDriver.onTextFrame(JettyListenerEventDriver.java:122)
    at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.incomingFrame(AbstractEventDriver.java:161)
    at org.eclipse.jetty.websocket.common.WebSocketSession.incomingFrame(WebSocketSession.java:309)
    at org.eclipse.jetty.websocket.common.extensions.ExtensionStack.incomingFrame(ExtensionStack.java:214)
    at org.eclipse.jetty.websocket.common.Parser.notifyFrame(Parser.java:220)
    at org.eclipse.jetty.websocket.common.Parser.parse(Parser.java:258)
    at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.readParse(AbstractWebSocketConnection.java:632)
    at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onFillable(AbstractWebSocketConnection.java:480)
    at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
    at java.lang.Thread.run(Unknown Source)
Tagsdialect: interbase, sql explorer

Relationships

duplicate of 0004145 closedpmarzullo SQL Explorer issue with Interbase as a node 

Activities

pmarzullo

2019-11-29 12:00

developer   ~0001658

This issue is a duplicate of 4145.

I will use 4145 to fix the issue.

Issue History

Date Modified Username Field Change
2017-06-30 10:18 gilles.riand New Issue
2017-07-12 13:52 chenson Project SymmetricDS => SymmetricDS Pro
2019-04-29 09:23 elong Summary SymmetricPRo version / With Interbase XE => SQL Explorer with Interbase XE gets unsupported JDBC method error
2019-05-09 13:32 elong Tag Attached: dialect: interbase
2019-05-09 13:32 elong Tag Attached: sql explorer
2019-11-29 11:58 pmarzullo Relationship added duplicate of 0004145
2019-11-29 12:00 pmarzullo Assigned To => pmarzullo
2019-11-29 12:00 pmarzullo Status new => closed
2019-11-29 12:00 pmarzullo Resolution open => duplicate
2019-11-29 12:00 pmarzullo Note Added: 0001658