View Issue Details

IDProjectCategoryView StatusLast Update
0003203SymmetricDSBugpublic2017-08-14 10:43
ReporterchensonAssigned Tomaxwellpettit 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.28 
Target Version3.8.29Fixed in Version3.8.29 
Summary0003203: list outgoing batches query does not work on Sybase ASE when a load is specified
DescriptionCaused by: org.jumpmind.db.sql.SqlException: Failed to execute sql: select b.node_id, b.channel_id, b.status, b.byte_count, b.extract_count, b.sent_count, b.load_count, b.data_event_count, b.reload_event_count, b.insert_event_count, b.update_event_count, b.delete_event_count, b.other_event_count, b.ignore_count, b.router_millis, b.network_millis, b.filter_millis, b.load_millis, b.extract_millis, b.sql_state, b.sql_code, b.sql_message, b.failed_data_id, b.last_update_hostname, b.last_update_time, b.create_time, b.batch_id, b.extract_job_flag, b.load_flag, b.error_flag, b.common_flag, b.load_id, b.create_by, b.summary from sym_outgoing_batch b where load_id in (?) order by batch_id desc
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:300)
    at org.jumpmind.db.sql.JdbcSqlReadCursor.<init>(JdbcSqlReadCursor.java:120)
    at org.jumpmind.db.sql.JdbcSqlTemplate.queryForCursor(JdbcSqlTemplate.java:140)
    at org.jumpmind.db.sql.AbstractSqlTemplate.query(AbstractSqlTemplate.java:199)
    at org.jumpmind.db.sql.AbstractSqlTemplate.query(AbstractSqlTemplate.java:195)
    at org.jumpmind.db.sql.AbstractSqlTemplate.query(AbstractSqlTemplate.java:158)
    at org.jumpmind.symmetric.service.impl.OutgoingBatchService.listOutgoingBatches(OutgoingBatchService.java:369)
    at com.jumpmind.symmetric.console.ui.screen.d.k.a(OutgoingBatchPanel.java:746)
    at com.jumpmind.symmetric.console.ui.screen.d.k.onRefresh(OutgoingBatchPanel.java:833)
    at com.jumpmind.symmetric.console.ui.common.AbstractMenuScreen.addToView(AbstractMenuScreen.java:233)
    at com.jumpmind.symmetric.console.ui.common.AbstractMenuScreen$3.run(AbstractMenuScreen.java:160)
    at com.jumpmind.symmetric.console.ui.common.AbstractMenuScreen.buttonClick(AbstractMenuScreen.java:170)
    at sun.reflect.GeneratedMethodAccessor44.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:508)
    ... 42 more
Caused by: com.sybase.jdbc4.jdbc.SybSQLException: Implicit conversion from datatype 'CHAR' to 'NUMERIC' is not allowed. Use the CONVERT function to run this query.

    at com.sybase.jdbc4.tds.Tds.processEed(Tds.java:3954)
    at com.sybase.jdbc4.tds.Tds.nextResult(Tds.java:3088)
    at com.sybase.jdbc4.tds.Tds.getResultSetResult(Tds.java:3820)
    at com.sybase.jdbc4.tds.TdsCursor.open(TdsCursor.java:329)
    at com.sybase.jdbc4.jdbc.SybStatement.executeQuery(SybStatement.java:2366)
    at com.sybase.jdbc4.jdbc.SybPreparedStatement.executeQuery(SybPreparedStatement.java:258)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
    at org.jumpmind.db.sql.JdbcSqlReadCursor.<init>(JdbcSqlReadCursor.java:97)
    ... 56 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 63bdc640

2017-08-01 15:37:05

maxwellpettit

Details Diff
0003203: list outgoing batches query does not work on Sybase ASE when a
load is specified

0003203
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/IIncomingBatchService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/IOutgoingBatchService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/AbstractService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/IncomingBatchService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/OutgoingBatchService.java Diff File

Issue History

Date Modified Username Field Change
2017-07-20 10:20 chenson New Issue
2017-07-20 10:20 chenson Status new => assigned
2017-07-20 10:20 chenson Assigned To => maxwellpettit
2017-08-01 15:39 maxwellpettit Status assigned => resolved
2017-08-01 15:39 maxwellpettit Fixed in Version => 3.8.29
2017-08-01 15:39 maxwellpettit Resolution open => fixed
2017-08-01 16:00 maxwellpettit Changeset attached => SymmetricDS 3.8 63bdc640
2017-08-14 10:43 chenson Status resolved => closed