View Issue Details

IDProjectCategoryView StatusLast Update
0003211SymmetricDSBugpublic2017-08-14 10:43
ReportergwilmerAssigned Togwilmer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.8.28 
Target Version3.8.29Fixed in Version3.8.29 
Summary0003211: When a node is in "offline" mode (node.offline=true), the offline push and pull jobs don't always pick up incoming files
DescriptionWhen a node is in "offline" mode (node.offline=true), the offline push and pull jobs don't always pick up incoming files.
Additional InformationOffline push/pull aren't picking up the files due to a bug in the caching logic in the NodeService that determines nodes to push to / pull from. There is a single variable that controls whether two separate caches are refreshed (one for target nodes, the other for source nodes). if one of the caches gets refreshed, the other does not.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 94b2c6cf

2017-07-29 10:18:29

gregwilmer

Details Diff
0003211 - Fix node group link caching in NodeService
0003211
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/NodeService.java Diff File

Issue History

Date Modified Username Field Change
2017-07-29 09:28 gwilmer New Issue
2017-07-29 09:28 gwilmer Status new => assigned
2017-07-29 09:28 gwilmer Assigned To => gwilmer
2017-07-29 10:21 gwilmer Resolution open => fixed
2017-07-29 10:21 gwilmer Fixed in Version => 3.8.29
2017-07-29 11:00 Changeset attached => SymmetricDS 3.8 94b2c6cf
2017-08-01 09:39 chenson Status assigned => resolved
2017-08-14 10:43 chenson Status resolved => closed