View Issue Details

IDProjectCategoryView StatusLast Update
0003253SymmetricDSBugpublic2018-02-14 15:08
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.0 
Target Version3.9.0Fixed in Version3.9.0 
Summary0003253: ProcessInfo which is used to gather information about processes can be corrupted on push and pull because of threading in 3.8
DescriptionProcessInfo which is used to gather information about processes can be corrupted on push and pull because of threading in 3.8

Need to break PUSH_JOB, PULL_JOB, PUSH_HANDLER and PULL_HANDLER into two different process types each.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.9 437ee696

2017-09-20 08:52:35

chenson42

Details Diff
0003253: ProcessInfo which is used to gather information about processes
can be corrupted on push and pull because of threading in 3.8

0003253
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ChannelMap.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ProcessInfo.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ProcessInfoKey.java Diff File
add - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ProcessType.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataLoaderService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/PushService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/transport/http/HttpOutgoingTransport.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/web/WebConstants.java Diff File
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/NodeConcurrencyInterceptor.java Diff File
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/PullUriHandler.java Diff File
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/PushUriHandler.java Diff File

SymmetricDS: 3.9 a146f60e

2017-09-21 08:53:47

chenson42

Details Diff
0003253: ProcessInfo which is used to gather information about processes
can be corrupted on push and pull because of threading in 3.8

0003253
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ProcessInfo.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ProcessInfoDataWriter.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ProcessInfoKey.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/RemoteNodeStatus.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/RemoteNodeStatuses.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/DataGapDetector.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/DataGapFastDetector.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/DataGapRouteReader.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataLoaderService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/FileSyncExtractorService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/FileSyncService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/OfflinePushService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/PushService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RegistrationService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RouterService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/transport/internal/InternalTransportManager.java Diff File
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/FileSyncPullUriHandler.java Diff File
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/PullUriHandler.java Diff File
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/rest/RestService.java Diff File

SymmetricDS: 3.9 58a32951

2017-09-21 13:47:07

chenson42

Details Diff
0003253: ProcessInfo which is used to gather information about processes
can be corrupted on push and pull because of threading in 3.8

0003253
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ProcessInfo.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/model/ProcessInfoDataWriter.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/statistic/StatisticManager.java Diff File
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/PullUriHandler.java Diff File

SymmetricDS: 3.9 c18a1507

2017-09-22 08:41:52

chenson42

Details Diff
0003253: ProcessInfo which is used to gather information about processes
can be corrupted on push and pull because of threading in 3.8

0003253
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File

SymmetricDS: 3.9 40b81577

2017-09-25 12:07:22

chenson42

Details Diff
0003253: processinfo for transfer goes to error if timeout is received
and the keep alive is pushed

0003253
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File

SymmetricDS: 3.9 2eda439c

2017-09-25 17:07:05

chenson42

Details Diff
0003253: ProcessInfo which is used to gather information about processes
can be corrupted on push and pull because of threading in 3.8

0003253
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File

SymmetricDS: 3.9 9fa4b8a0

2017-12-06 11:52:25

chenson42

Details Diff
0003253: ProcessInfo which is used to gather information about processes
can be corrupted on push and pull because of threading in 3.8

0003253
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataLoaderService.java Diff File

SymmetricDS: 3.9 525905c8

2017-12-12 20:49:13

chenson42

Details Diff
0003253: ProcessInfo which is used to gather information about processes
can be corrupted on push and pull because of threading in 3.8

0003253
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataLoaderService.java Diff File

Issue History

Date Modified Username Field Change
2017-09-20 08:52 chenson New Issue
2017-09-20 08:52 chenson Status new => assigned
2017-09-20 08:52 chenson Assigned To => chenson
2017-09-22 16:02 chenson Status assigned => resolved
2017-09-22 16:02 chenson Resolution open => fixed
2017-09-22 16:02 chenson Fixed in Version => 3.9.0
2017-12-15 16:21 mmichalek Status resolved => closed
2018-02-14 15:08 chenson42 Changeset attached => SymmetricDS 3.9 525905c8
2018-02-14 15:08 chenson42 Changeset attached => SymmetricDS 3.9 9fa4b8a0
2018-02-14 15:08 chenson42 Changeset attached => SymmetricDS 3.9 2eda439c
2018-02-14 15:08 chenson42 Changeset attached => SymmetricDS 3.9 40b81577
2018-02-14 15:08 chenson42 Changeset attached => SymmetricDS 3.9 c18a1507
2018-02-14 15:08 chenson42 Changeset attached => SymmetricDS 3.9 58a32951
2018-02-14 15:08 chenson42 Changeset attached => SymmetricDS 3.9 a146f60e
2018-02-14 15:08 chenson42 Changeset attached => SymmetricDS 3.9 437ee696