View Issue Details

IDProjectCategoryView StatusLast Update
0003269SymmetricDSBugpublic2017-10-06 07:51
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.0 
Target Version3.8.30Fixed in Version3.8.30 
Summary0003269: If a file exists in staging with a done or create suffix and no period to separate the suffix, then the server won't startup
DescriptionIf a file exists in staging with a done or create suffix and no period to separate the suffix, then the server won't startup.


2017-10-03 19:40:49,034 ERROR [SymmetricDS] [SymmetricEngineHolder] [symmetric-engine-startup-0] StackTraceKey.init [StringIndexOutOfBoundsException:1850240440]
java.lang.StringIndexOutOfBoundsException: String index out of range: -2
        at java.lang.String.substring(String.java:1967)
        at org.jumpmind.symmetric.io.stage.StagedResource.toPath(StagedResource.java:96)
        at org.jumpmind.symmetric.io.stage.StagingManager.refreshResourceList(StagingManager.java:72)
        at org.jumpmind.symmetric.io.stage.StagingManager.<init>(StagingManager.java:58)
        at org.jumpmind.symmetric.io.stage.BatchStagingManager.<init>(BatchStagingManager.java:21)
        at org.jumpmind.symmetric.ClientSymmetricEngine.createStagingManager(ClientSymmetricEngine.java:360)
        at org.jumpmind.symmetric.AbstractSymmetricEngine.init(AbstractSymmetricEngine.java:324)
        at org.jumpmind.symmetric.ClientSymmetricEngine.init(ClientSymmetricEngine.java:184)
        at org.jumpmind.symmetric.web.ServerSymmetricEngine.init(ServerSymmetricEngine.java:66)
        at org.jumpmind.symmetric.ClientSymmetricEngine.<init>(ClientSymmetricEngine.java:151)
        at org.jumpmind.symmetric.web.ServerSymmetricEngine.<init>(ServerSymmetricEngine.java:51)
        at org.jumpmind.symmetric.web.SymmetricEngineHolder.create(SymmetricEngineHolder.java:247)
        at org.jumpmind.symmetric.web.SymmetricEngineHolder$EngineStarter.run(SymmetricEngineHolder.java:527)
2017-10-03 19:41:56,919 WARN [?] [SymmetricServlet] [http-bio-8080-exec-8] The client node request is being rejected because the server node does not exist. Please check that the engine.name exists in the url. It should be of the pattern http://host:port/sync/{engine.name}/{action}. If it does not, then check the sync.url of this node or the registration.url of the client making the request. The request was /SymmetricDS/registration from the host 172.16.184.74 with an ip address of 172.16.184.74. The query string was: nodeGroupId=client&externalId=08255&syncURL=http%3A%2F%2Fsymmetric.08255.arch-ref.devrhythmforstores.com%3A8080%2FSymmetricDS%2Fsync%2FSymmetricDS&schemaVersion=%3F&databaseType=PostgreSQL&databaseVersion=9.6&symmetricVersion=3.8.18&hostName=symmetric.arch-ref&ipAddress=172.16.185.76
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 b0577ffb

2017-10-03 18:20:44

chenson42

Details Diff
0003269: If a file exists in staging with a done or create suffix and no
period to separate the suffix, then the server won't startup

0003269
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagedResource.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/stage/StagingManager.java Diff File

Issue History

Date Modified Username Field Change
2017-10-03 18:20 chenson New Issue
2017-10-03 18:20 chenson Status new => assigned
2017-10-03 18:20 chenson Assigned To => chenson
2017-10-03 18:21 chenson Status assigned => resolved
2017-10-03 18:21 chenson Resolution open => fixed
2017-10-03 18:21 chenson Fixed in Version => 3.8.30
2017-10-03 19:00 chenson42 Changeset attached => SymmetricDS 3.8 b0577ffb
2017-10-06 07:51 chenson Status resolved => closed