View Issue Details

IDProjectCategoryView StatusLast Update
0003309SymmetricDSBugpublic2019-02-27 08:55
Reportersunil.maliAssigned Toadmin 
Priorityurgent 
Status closedResolutionduplicate 
Product Version3.8.9 
Target VersionFixed in Version3.8.23 
Summary0003309: [main] - DataLoaderService - Failed while parsing batch java.lang.NullPointerException
DescriptionHi,
I am getting this error

[main] - DataLoaderService - Failed while parsing batch
java.lang.NullPointerException
        at org.jumpmind.symmetric.io.data.writer.SimpleStagingDataWriter.writeLine(SimpleStagingDataWriter.java:218)
        at org.jumpmind.symmetric.io.data.writer.SimpleStagingDataWriter.process(SimpleStagingDataWriter.java:179)
        at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromTransport(DataLoaderService.java:500)
        at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromPush(DataLoaderService.java:384)
        at org.jumpmind.symmetric.web.PushUriHandler.push(PushUriHandler.java:83)
        at org.jumpmind.symmetric.web.PushUriHandler.handle(PushUriHandler.java:68)
        at org.jumpmind.symmetric.web.SymmetricServlet.service(SymmetricServlet.java:114)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:230)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:165)
        at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:192)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:165)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:198)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:96)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:474)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:140)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:79)
        at org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:624)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:87)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:349)
        at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:783)
        at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)
        at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:798)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1434)
        at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Thread.java:745)


Everything was working fine till 5th Nov 2017.
on 6th nov my m/c got shutdown abruptly. Since that time the data not getting pushed to main server from slave server.
PLease suggest steps or solution to solve this problem .

Thanks
Sunil Mali
Additional InformationM/c got shutdown abruptly. Windows 7 is the OS
TagsNo tags attached.

Relationships

duplicate of 0003091 closedchenson A corrupt batch being sent to a target results in a NullPointerException by load writing the batch to staging 

Activities

sunil.mali

2017-11-10 04:12

reporter   ~0001077

Database we are using is mysql

hanes

2018-10-17 10:10

developer   ~0001277

Are you still observing this issue in the most recent version of 3.8? We'd need to know more details about the batch itself to be able recreate.

Issue History

Date Modified Username Field Change
2017-11-10 04:11 sunil.mali New Issue
2017-11-10 04:12 sunil.mali Note Added: 0001077
2018-10-17 10:10 hanes Status new => feedback
2018-10-17 10:10 hanes Note Added: 0001277
2019-02-27 08:52 admin Relationship added duplicate of 0003091
2019-02-27 08:55 admin Assigned To => admin
2019-02-27 08:55 admin Status feedback => closed
2019-02-27 08:55 admin Resolution open => duplicate
2019-02-27 08:55 admin Fixed in Version => 3.8.23