View Issue Details

IDProjectCategoryView StatusLast Update
0003320SymmetricDSBugpublic2017-11-20 11:00
ReportermmichalekAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.0 
Target Version3.8.32Fixed in Version3.8.32 
Summary0003320: Possible NullPointerException during extension registration on a busy system
DescriptionSometimes when adding an extension to the database on a running, busy system, and NullPointerException like this could occur:

2017-11-09 18:08:58,411 INFO [server] [ExtensionService] [qtp1476394199-16] Found 1 extension points from the database that will be registered
2017-11-09 18:08:58,412 INFO [server] [SimpleClassCompiler] [qtp1476394199-16] Compiling class 'StressTestHeartbeatListener'
2017-11-09 18:08:59,968 INFO [server] [ExtensionService] [qtp1476394199-16] Registering extension named 'test' of type 'IHeartbeatListener'
2017-11-09 18:08:59,968 INFO [server] [ClientExtensionService] [qtp1476394199-16] Found 14 extension points from spring that will be registered
2017-11-09 18:08:59,971 ERROR [server] [SymmetricServlet] [qtp1476394199-12] Error while processing GET request for node: 2dcaa5bb21d1 at 54.236.48.238 with path: /server/pull StackTraceKey.init [NullPointerException:2076862173]
java.lang.NullPointerException
    at com.jumpmind.symmetric.console.remote.RemoteStatusInterceptor.before(RemoteStatusInterceptor.java:56)
    at org.jumpmind.symmetric.web.SymmetricServlet.service(SymmetricServlet.java:107)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:833)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1650)
    at org.eclipse.jetty.websocket.server.WebSocketUpgradeFilter.doFilter(WebSocketUpgradeFilter.java:206)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1637)
    at org.jumpmind.symmetric.web.HttpMethodFilter.doFilter(HttpMethodFilter.java:62)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1637)
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:533)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:548)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:132)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:190)
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:1595)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:188)
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1253)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:168)
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:473)
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:1564)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:166)
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1155)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:132)
    at org.eclipse.jetty.server.Server.handle(Server.java:561)
    at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:334)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:251)
    at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:279)
    at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:104)
    at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:124)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:247)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.produce(EatWhatYouKill.java:140)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:131)
    at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:243)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:679)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:597)
    at java.lang.Thread.run(Thread.java:748)
2017-11-09 18:08:59,971 ERROR [server] [SymmetricServlet] [qtp1476394199-14] Error while processing GET request for node: b26c633fcf1e at 52.201.228.223 with path: /server/pull StackTraceKey [NullPointerException:2076862173]
2017-11-09 18:09:03,755 INFO [server] [ConfigurationChangedDataRouter] [server-job-4] About to refresh the cache of extensions because new configuration came through the data router
2017-11-09 18:09:03,764 INFO [server] [ExtensionService] [server-job-4] Found 1 extension points from the database that will be registered
2017-11-09 18:09:03,764 INFO [server] [ExtensionService] [server-job-4] Registering extension named 'test' of type 'IHeartbeatListener'
2017-11-09 18:09:03,770 INFO [server] [ClientExtensionService] [server-job-4] Found 14 extension points from spring that will be registered
2017-11-09 18:09:03,770 INFO [server] [RouterService] [server-job-4] Routed 10 data events in 100 ms
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.8 ba8243a0

2017-11-20 10:07:15

mmichalek

Details Diff
0003320: Possible NullPointerException during extension registration on
a busy system

0003320
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/service/impl/ClientExtensionService.java Diff File

Issue History

Date Modified Username Field Change
2017-11-20 10:05 mmichalek New Issue
2017-11-20 10:05 mmichalek Status new => assigned
2017-11-20 10:05 mmichalek Assigned To => mmichalek
2017-11-20 10:08 mmichalek Status assigned => resolved
2017-11-20 10:08 mmichalek Resolution open => fixed
2017-11-20 10:08 mmichalek Fixed in Version => 3.8.32
2017-11-20 10:34 mmichalek Status resolved => closed
2017-11-20 11:00 mmichalek Changeset attached => SymmetricDS 3.8 ba8243a0