View Issue Details

IDProjectCategoryView StatusLast Update
0003331SymmetricDSBugpublic2017-12-13 17:23
ReportermmichalekAssigned Tokstojanovska 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.8.32 
Target Version3.8.33Fixed in Version3.8.33 
Summary0003331: Fix sql maps to avoid using hard coded prefixes to tables.
DescriptionFix sql maps to avoid using hard coded prefixes to tables.

When using a different table prefix, as in:
sync.table.prefix=sds

Results in errors accessing the outgoing_batch.

017-12-06 17:04:28,951 ERROR [regsvr] [HeartbeatJob] [qtp633070006-16] StackTraceKey.init [SqlException:3389318759]
org.jumpmind.db.sql.SqlException: Failed to execute sql: select node_id, batch_id from sym_outgoing_batch where channel_id = ? and status <> ? and summary=?
     at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:300)
     at org.jumpmind.db.sql.JdbcSqlReadCursor.<init>(JdbcSqlReadCursor.java:120)
     at org.jumpmind.db.sql.JdbcSqlTemplate.queryForCursor(JdbcSqlTemplate.java:140)
     at org.jumpmind.db.sql.AbstractSqlTemplate.query(AbstractSqlTemplate.java:199)
     at org.jumpmind.db.sql.AbstractSqlTemplate.query(AbstractSqlTemplate.java:195)
     at org.jumpmind.db.sql.AbstractSqlTemplate.query(AbstractSqlTemplate.java:185)
     at org.jumpmind.db.sql.AbstractSqlTemplate.query(AbstractSqlTemplate.java:121)
     at org.jumpmind.db.sql.AbstractSqlTemplate.query(AbstractSqlTemplate.java:177)
     at org.jumpmind.symmetric.service.impl.OutgoingBatchService.markAllChannelAsSent(OutgoingBatchService.java:163)
     at org.jumpmind.symmetric.job.PushHeartbeatListener.heartbeat(PushHeartbeatListener.java:92)
     at org.jumpmind.symmetric.service.impl.DataService.heartbeat(DataService.java:2135)
     at org.jumpmind.symmetric.job.HeartbeatJob.doJob(HeartbeatJob.java:56)
     at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:177)
     at com.jumpmind.symmetric.console.ui.screen.d.f$5.buttonClick(JobsPanel.java:148)
     at sun.reflect.GeneratedMethodAccessor56.invoke(Unknown Source)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.lang.reflect.Method.invoke(Method.java:498)
     at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:508)
     at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:198)
     at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:161)
     at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1008)
     at com.vaadin.ui.Button.fireClick(Button.java:377)
     at com.vaadin.ui.Button$1.click(Button.java:54)
     at sun.reflect.GeneratedMethodAccessor55.invoke(Unknown Source)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.lang.reflect.Method.invoke(Method.java:498)
     at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:158)
     at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:118)
     at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:408)
     at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:273)
     at com.vaadin.server.communication.PushHandler$2.run(PushHandler.java:149)
     at com.vaadin.server.communication.PushHandler.callWithUi(PushHandler.java:243)
     at com.vaadin.server.communication.PushHandler.onMessage(PushHandler.java:503)
     at com.vaadin.server.communication.PushAtmosphereHandler.onMessage(PushAtmosphereHandler.java:88)
     at com.vaadin.server.communication.PushAtmosphereHandler.onRequest(PushAtmosphereHandler.java:78)
     at org.atmosphere.cpr.AsynchronousProcessor.action(AsynchronousProcessor.java:199)
     at org.atmosphere.cpr.AsynchronousProcessor.suspended(AsynchronousProcessor.java:107)
     at org.atmosphere.container.Jetty9AsyncSupportWithWebSocket.service(Jetty9AsyncSupportWithWebSocket.java:180)
     at org.atmosphere.cpr.AtmosphereFramework.doCometSupport(AtmosphereFramework.java:2075)
     at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:571)
     at org.atmosphere.websocket.DefaultWebSocketProcessor$3.run(DefaultWebSocketProcessor.java:333)
     at org.atmosphere.util.VoidExecutorService.execute(VoidExecutorService.java:101)
     at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:328)
     at org.atmosphere.websocket.DefaultWebSocketProcessor.invokeWebSocketProtocol(DefaultWebSocketProcessor.java:425)
     at org.atmosphere.container.Jetty9WebSocketHandler.onWebSocketText(Jetty9WebSocketHandler.java:92)
     at org.eclipse.jetty.websocket.common.events.JettyListenerEventDriver.onTextMessage(JettyListenerEventDriver.java:128)
     at org.eclipse.jetty.websocket.common.message.SimpleTextMessage.messageComplete(SimpleTextMessage.java:69)
     at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.appendMessage(AbstractEventDriver.java:65)
     at org.eclipse.jetty.websocket.common.events.JettyListenerEventDriver.onTextFrame(JettyListenerEventDriver.java:122)
     at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.incomingFrame(AbstractEventDriver.java:161)
     at org.eclipse.jetty.websocket.common.WebSocketSession.incomingFrame(WebSocketSession.java:309)
     at org.eclipse.jetty.websocket.common.extensions.ExtensionStack.incomingFrame(ExtensionStack.java:214)
     at org.eclipse.jetty.websocket.common.Parser.notifyFrame(Parser.java:220)
     at org.eclipse.jetty.websocket.common.Parser.parse(Parser.java:258)
     at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.readParse(AbstractWebSocketConnection.java:632)
     at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onFillable(AbstractWebSocketConnection.java:480)
     at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
     at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
     at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
     at java.lang.Thread.run(Thread.java:748)
Caused by: org.postgresql.util.PSQLException: ERROR: relation "sym_outgoing_batch" does not exist
Position: 31
     at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2455)
     at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:2155)
     at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:288)
     at org.postgresql.jdbc.PgStatement.executeInternal(PgStatement.java:430)
     at org.postgresql.jdbc.PgStatement.execute(PgStatement.java:356)
     at org.postgresql.jdbc.PgPreparedStatement.executeWithFlags(PgPreparedStatement.java:168)
     at org.postgresql.jdbc.PgPreparedStatement.executeQuery(PgPreparedStatement.java:116)
     at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
     at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
     at org.jumpmind.db.sql.JdbcSqlReadCursor.<init>(JdbcSqlReadCursor.java:97)
     ... 58 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-12-06 17:12 mmichalek New Issue
2017-12-06 17:12 mmichalek Status new => assigned
2017-12-06 17:12 mmichalek Assigned To => kstojanovska
2017-12-13 17:23 mmichalek Status assigned => resolved
2017-12-13 17:23 mmichalek Resolution open => fixed
2017-12-13 17:23 mmichalek Fixed in Version => 3.8.33
2017-12-13 17:23 mmichalek Status resolved => closed