View Issue Details

IDProjectCategoryView StatusLast Update
0003344SymmetricDSBugpublic2019-01-09 14:00
Reporterivan.konevAssigned Topmarzullo 
Priorityhigh 
Status resolvedResolutionfixed 
Product Version3.9.1 
Target Version3.10.0Fixed in Version3.10.0 
Summary0003344: start.refresh.cache.job=true leads to errors in cache refresh job - "query error" with query = 'null'
DescriptionNot affecting overall performance and ability to sync, periodic refresh cache job fails completely giving something like below. For any of used engines - mysql,mariadb,oracle,sqlite...
Steps To Reproducestart.cache.refresh.job=true
Additional Information2017-12-23 12:55:00,013 ERROR [mysqlmariadbnode] [RefreshCacheJob] [mysqlmariadbnode-job-11] Exception while executing job 'Refresh Cache' StackTraceKey.init [SqlException:265184862]
org.jumpmind.db.sql.SqlException: (conn=2312) You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'null' at line 1
        at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:300)
        at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:291)
        at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:493)
        at org.jumpmind.db.sql.JdbcSqlTemplate.queryForObject(JdbcSqlTemplate.java:156)
        at org.jumpmind.symmetric.service.impl.FileSyncService.refreshFromDatabase(FileSyncService.java:121)
        at org.jumpmind.symmetric.job.RefreshCacheJob.doJob(RefreshCacheJob.java:52)
        at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:225)
        at org.jumpmind.symmetric.job.AbstractJob.run(AbstractJob.java:287)
        at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:54)
        at org.springframework.scheduling.concurrent.ReschedulingRunnable.run(ReschedulingRunnable.java:81)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)
Caused by: java.sql.SQLSyntaxErrorException: (conn=2312) You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'null' at line 1
        at org.mariadb.jdbc.internal.util.exceptions.ExceptionMapper.get(ExceptionMapper.java:177)
        at org.mariadb.jdbc.internal.util.exceptions.ExceptionMapper.getException(ExceptionMapper.java:110)
        at org.mariadb.jdbc.MariaDbStatement.executeExceptionEpilogue(MariaDbStatement.java:235)
        at org.mariadb.jdbc.MariaDbPreparedStatementClient.executeInternal(MariaDbPreparedStatementClient.java:224)
        at org.mariadb.jdbc.MariaDbPreparedStatementClient.execute(MariaDbPreparedStatementClient.java:159)
        at org.mariadb.jdbc.MariaDbPreparedStatementClient.executeQuery(MariaDbPreparedStatementClient.java:173)
        at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
        at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
        at org.jumpmind.db.sql.JdbcSqlTemplate$1.execute(JdbcSqlTemplate.java:168)
        at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:491)
        ... 14 more
Caused by: java.sql.SQLException: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'null' at line 1
Query is: null
        at org.mariadb.jdbc.internal.util.LogQueryTool.exceptionWithQuery(LogQueryTool.java:153)
        at org.mariadb.jdbc.internal.protocol.AbstractQueryProtocol.executeQuery(AbstractQueryProtocol.java:248)
        at org.mariadb.jdbc.MariaDbPreparedStatementClient.executeInternal(MariaDbPreparedStatementClient.java:218)
        ... 20 more

Activities

hanes

2018-10-17 13:25

developer   ~0001282

Recreated under 3.9.14. Placed start.refresh.cache.job=true into symmetric-server.properties file and started node.

hanes

2018-10-17 14:35

developer   ~0001286

For 3.10 this refresh cache feature needs to be finished and documented or removed.

mmichalek

2019-01-08 10:28

administrator   ~0001370

Spend a couple minutes seeing if it's an easy fix. Otherwise, consensus is to leave parameter and job but leave job unimplemented (maybe throw exception indicating that this is not implemented)

pmarzullo

2019-01-09 13:46

developer   ~0001372

Code was using the wrong name to retrieve the query for the refreshFromDatabase (selectMaxTriggerLastUpdateTime, should have been selectMaxFileTriggerLastUpdateTime)

Related Changesets

SymmetricDS: 3.10 48953ca5

2019-01-09 13:09:51

philipmarzullo

Details Diff
0003344: start.refresh.cache.job=true leads to errors in cache refresh
job - "query error" with query = 'null'

0003344
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/FileSyncService.java Diff File

Issue History

Date Modified Username Field Change
2017-12-23 04:58 ivan.konev New Issue
2018-10-17 13:25 hanes Status new => confirmed
2018-10-17 13:25 hanes Note Added: 0001282
2018-10-17 14:35 hanes Note Added: 0001286
2018-10-17 14:35 hanes Target Version => 3.10.0
2018-12-05 14:59 hanes Priority normal => high
2019-01-08 10:28 mmichalek Note Added: 0001370
2019-01-08 10:30 josh-a-hicks Assigned To => pmarzullo
2019-01-08 10:30 josh-a-hicks Status confirmed => assigned
2019-01-09 13:46 pmarzullo Status assigned => resolved
2019-01-09 13:46 pmarzullo Resolution open => fixed
2019-01-09 13:46 pmarzullo Fixed in Version => 3.10.0
2019-01-09 13:46 pmarzullo Note Added: 0001372
2019-01-09 14:00 Changeset attached => SymmetricDS 3.10 48953ca5