View Issue Details

IDProjectCategoryView StatusLast Update
0003384SymmetricDSBugpublic2019-04-24 13:18
ReporterjflambertAssigned Toelong 
Prioritynormal 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.10.0 
Summary0003384: Various warnings appear when executing symadmin send-schema
DescriptionFollowing the steps to replicate DDL as per: https://www.symmetricds.org/docs/how-to/sync-schema-ddl-changes

Many warnings appear on screen but otherwise the DDL replication seems successful.
Steps To Reproduce# sync triggers on staging
symadmin --engine staging sync-triggers

# send schema changes to production
./symadmin --engine staging send-schema --node production
[staging] - AbstractSymmetricEngine - Initializing connection to database
[staging] - JdbcDatabasePlatformFactory - Detected database 'PostgreSQL', version '9', protocol 'postgresql'
[staging] - JdbcDatabasePlatformFactory - The IDatabasePlatform being used is org.jumpmind.db.platform.postgresql.PostgreSqlDatabasePlatform
[staging] - PostgreSqlSymmetricDialect - The DbDialect being used is org.jumpmind.symmetric.db.postgresql.PostgreSqlSymmetricDialect
[staging] - ExtensionService - Found 0 extension points from the database that will be registered
[staging] - StagingManager - The staging directory was initialized at the following location: /opt/symmetric-server-3.9.2/tmp/staging
[staging] - ClusterService - This node picked a server id of ntx-jeff78
[staging] - ExtensionService - Found 0 extension points from the database that will be registered
[staging] - ClientExtensionService - Found 6 extension points from spring that will be registered
[staging] - Database - Unable to resolve foreign keys for table sym_conflict because the following dependent tables were not included [sym_node_group_link].
[staging] - Database - Unable to resolve foreign keys for table sym_file_trigger_router because the following dependent tables were not included [sym_file_triggersym_router].
[staging] - Database - Unable to resolve foreign keys for table sym_file_trigger_router because the following dependent tables were not included [sym_file_triggersym_router].
[staging] - Database - Unable to resolve foreign keys for table sym_grouplet_link because the following dependent tables were not included [sym_grouplet].
[staging] - Database - Unable to resolve foreign keys for table sym_node_group_link because the following dependent tables were not included [sym_node_groupsym_node_group].
[staging] - Database - Unable to resolve foreign keys for table sym_node_group_link because the following dependent tables were not included [sym_node_groupsym_node_group].
[staging] - Database - Unable to resolve foreign keys for table sym_node_identity because the following dependent tables were not included [sym_node].
[staging] - Database - Unable to resolve foreign keys for table sym_node_security because the following dependent tables were not included [sym_node].
[staging] - Database - Unable to resolve foreign keys for table sym_router because the following dependent tables were not included [sym_node_group_link].
[staging] - Database - Unable to resolve foreign keys for table sym_transform_table because the following dependent tables were not included [sym_node_group_link].
[staging] - Database - Unable to resolve foreign keys for table sym_trigger because the following dependent tables were not included [sym_channelsym_channel].
[staging] - Database - Unable to resolve foreign keys for table sym_trigger because the following dependent tables were not included [sym_channelsym_channel].
[staging] - Database - Unable to resolve foreign keys for table sym_trigger_router because the following dependent tables were not included [sym_routersym_trigger].
[staging] - Database - Unable to resolve foreign keys for table sym_trigger_router because the following dependent tables were not included [sym_routersym_trigger].
[staging] - Database - Unable to resolve foreign keys for table sym_trigger_router_grouplet because the following dependent tables were not included [sym_groupletsym_trigger_router].
[staging] - Database - Unable to resolve foreign keys for table sym_trigger_router_grouplet because the following dependent tables were not included [sym_groupletsym_trigger_router].
Additional Informationsymmetric.log shows the same warnings as well as the tables being recreated with the new DDL (success)
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-01-19 13:26 jflambert New Issue
2019-04-24 13:18 elong Assigned To => elong
2019-04-24 13:18 elong Status new => closed
2019-04-24 13:18 elong Resolution open => fixed
2019-04-24 13:18 elong Fixed in Version => 3.10.0