View Issue Details

IDProjectCategoryView StatusLast Update
0003388SymmetricDSBugpublic2019-08-26 08:45
ReportersnpeAssigned Toelong 
Prioritynormal 
Status closedResolutionopen 
Product Version3.9.2 
Target VersionFixed in Version 
Summary0003388: SQL Anywhere triggers issue
DescriptionSymmetricDS creates T-SQL triggers on SQLAnywhere - http://dcx.sybase.com/1200/en/dbreference/create-trigger-tsql-statement.html
These triggers have default ORDER 1 and always run BEFORE other database "after" triggers (other triggers have to have ORDER > 1 when using Symmetricds).
So, the changes created by other database triggers aren't replicated.

Solution: convert SQLAnywhere triggers to WATCOM SQL - http://dcx.sybase.com/1200/en/dbreference/create-trigger-statement.html
Steps To Reproduce- create a trigger in SQLAnywhere that change something. The changes within triggers will not be replicated.
Additional InformationI'm willing to update a patch since I have fixed it for us, but we have to use patched SymmetricDS on SQL Anywhere 11.
Tagsdialect: sql anywhere

Activities

elong

2019-04-24 13:23

developer   ~0001432

If you sign the online CLA and submit a patch, we'll merge it in: https://www.symmetricds.org/developer/contributor

admin

2019-08-26 08:45

administrator   ~0001582

Auto closing all issues waiting for feedback after 4 months. We don't have enough information to take any action.

Issue History

Date Modified Username Field Change
2018-01-21 16:18 snpe New Issue
2019-04-24 13:19 elong Tag Attached: dialect: sql anywhere
2019-04-24 13:23 elong Assigned To => elong
2019-04-24 13:23 elong Status new => feedback
2019-04-24 13:23 elong Note Added: 0001432
2019-08-26 08:45 admin Note Added: 0001582
2019-08-26 08:45 admin Status feedback => closed