View Issue Details

IDProjectCategoryView StatusLast Update
0003397SymmetricDSBugpublic2019-04-23 11:41
Reporteranthony.vitale@sonymusic.comAssigned Toelong 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.9.2 
Target Version3.10.1Fixed in Version3.10.1 
Summary0003397: Using Postgresql 9.6.6 as a Source DB Fails SymmetricDS Upgrade to version 3.9.2 due to old postgresql jdbc driver
DescriptionThis Version of the JDBC Driver has a Issue with PostgreSql verion 9.1 and above in that when it accesses the Postgresql Catalog table pg_trigger in order to look up Catalog Metadata AND it selects a non existant column pg_trigger.tgisconstraint which was dropped from PostgreSQL in Version 9.2 and Above.

I know of this issue specifically when I tried to do a SymmetricDS Upgrade as during the upgrade I assume the SymmetricDS Code is using JDBC Methods which fail with the error

t1.tgisconstraint does not exist.

This is Due to Postgresql Removing this column from the catalog with the release of Postgresql 9.2.4

As Such We replaced the postgresql-9.4-1212.jre7.jar found within the SymmetricDS released lib directory with the Current PostgreSQL JDBC Driver postgresql-42.1.4.jar which works with PGSQL 9.2 and above and no longer references t1.tgisconstraint within the JDBC Driver's methods.

So Please replace the PostgreSQL JDBC driver released with the SymmetricDS to be the Current Version postgresql-42.1.4.jar or whatever the most Current Postgresql JDBC Driver at the Time of Repair of this Issue.

I know that each installation can Supply there own JDBC Drivers, however it would be better to not supply Any JDBC Driver with the Symmetric Release instead of a JDBC Driver which causes Issues in Performing Upgrades.

Thanks
Anthony Vitale
Steps To ReproduceUse Symmds 9.4.2 to upgrade from any Prior Symmds Release using either the Source or Target node being Postgresql version 9.4 and above.
Tagsdialect: postgresql, upgrade

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-01-31 16:19 anthony.vitale@sonymusic.com New Issue
2018-01-31 16:19 anthony.vitale@sonymusic.com Tag Attached: postgresql
2018-01-31 16:19 anthony.vitale@sonymusic.com Tag Attached: tgisconstraint
2018-01-31 16:19 anthony.vitale@sonymusic.com Tag Attached: Upgrade
2019-04-12 12:33 admin Tag Detached: tgisconstraint
2019-04-23 08:24 elong Assigned To => elong
2019-04-23 08:24 elong Status new => resolved
2019-04-23 08:24 elong Resolution open => fixed
2019-04-23 08:24 elong Fixed in Version => 3.10.1
2019-04-23 08:24 elong Target Version => 3.10.1
2019-04-23 11:41 elong Status resolved => closed
2019-04-23 16:50 admin Tag Renamed postgresql => dialect: postgresql