View Issue Details

IDProjectCategoryView StatusLast Update
0003409SymmetricDSBugpublic2018-12-05 14:58
ReporterabrougherAssigned To 
Prioritynormal 
Status closedResolutionduplicate 
Product Version3.9.0 
Target Version3.10.0Fixed in Version 
Summary0003409: Cascade clause is not being exported in the SQL DDL when syncing table DDL.
DescriptionWhen syncing table DDL, the DDL generated does not include the cascade clause. See steps to reproduce below.
Steps To ReproduceTo recreate on an H2 db...

--
-- Create example tables to export
--
CREATE TABLE PARENT (
    PARENT_ID VARCHAR(25) NOT NULL,
    PRIMARY KEY(PARENT_ID)
);
CREATE TABLE CHILD (
    ID SMALLINT AUTO_INCREMENT,
    PARENT_ID VARCHAR(25) NOT NULL,
    PRIMARY KEY(ID),
        CONSTRAINT FK_PARENT_CHILD FOREIGN KEY(PARENT_ID) REFERENCES PARENT(PARENT_ID) ON DELETE CASCADE
);

--
-- Table DDL generated by DDLUtils
--
CREATE TABLE CHILD(
    ID SMALLINT NOT NULL AUTO_INCREMENT,
    PARENT_ID VARCHAR(25) NOT NULL,
    PRIMARY KEY (ID)
);
ALTER TABLE CHILD
    ADD CONSTRAINT FK_PARENT_CHILD FOREIGN KEY (PARENT_ID) REFERENCES PARENT (PARENT_ID);

Relationships

duplicate of 0003537 acknowledged initial load create: Cascade Delete rule is not syncing as part of the create DDL 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-02-07 12:32 abrougher New Issue
2018-10-10 14:08 hanes Status new => acknowledged
2018-10-10 14:08 hanes Target Version => 3.10.0
2018-10-25 15:23 hanes Project SymmetricDS Pro => SymmetricDS
2018-12-05 14:58 hanes Status acknowledged => closed
2018-12-05 14:58 hanes Resolution open => duplicate
2018-12-05 14:58 hanes Relationship added duplicate of 0003537