View Issue Details

IDProjectCategoryView StatusLast Update
0003438SymmetricDSNew Featurepublic2019-04-12 08:49
ReporterzulusAssigned To 
Prioritylow 
Status closedResolutionduplicate 
Product Version3.8.33 
Target VersionFixed in Version3.8.31 
Summary0003438: Provide parameter to pass Oracle's DATE field's time part over to target database by mapping to a timestamp instead of just DATE
DescriptionOracle's DATE field per documentation is just a date, but in practice can contain time information. Provide a new parameter to control whether the field should be treated as just a DATE (as currently is the case) or whether to treat it as date and time.

Original Bug Description: Oracle date field can (and often) contain time part, unfortunately SymmetricDS transform it to postgresql date field and "time" part is lost, also after sync-schema.
Steps To ReproduceCreate Oracle Table with "date" field.
Run symadmin sync-schema.
Tagsdialect: oracle

Relationships

duplicate of 0003297 closedkstojanovska Treat Oracle DATE type as a TIMESTAMP 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-02-21 06:42 zulus New Issue
2018-02-21 06:42 zulus Tag Attached: postgres
2018-02-21 06:42 zulus Tag Attached: oracle
2018-10-17 14:26 hanes Status new => confirmed
2018-10-17 14:26 hanes Category Bug => New Feature
2018-10-17 14:26 hanes Target Version => 3.10.0
2018-10-17 14:26 hanes Summary Oracle date is transformed to Postgresql date => Provide parameter to pass Oracle's DATE field's time part over to target database by mapping to a timestamp instead of just DATE
2018-10-17 14:26 hanes Description Updated View Revisions
2018-10-25 15:19 hanes Status confirmed => closed
2018-10-25 15:19 hanes Resolution open => duplicate
2018-10-25 15:19 hanes Relationship added duplicate of 0003297
2018-10-29 12:55 hanes Priority normal => low
2019-03-14 08:45 admin Fixed in Version => 3.8.31
2019-03-14 08:45 admin Target Version 3.10.0 =>
2019-04-12 08:49 admin Tag Detached: postgres
2019-04-23 16:50 admin Tag Renamed oracle => dialect: oracle