View Issue Details

IDProjectCategoryView StatusLast Update
0003562SymmetricDS ProBugpublic2018-10-10 08:38
ReportermmichalekAssigned Tohanes 
Prioritynormal 
Status closedResolutionno change required 
Product Version3.9.6 
Target VersionFixed in Version 
Summary0003562: ConcurrentModificationException on UI background refresher thread
DescriptionObserved this on a 3.9.6 system with 12 multi-home nodes.

2018-05-14 13:53:29,834 ERROR [Source] [a] [background-refresher-1] Exception while refreshing class com.jumpmind.symmetric.console.ui.screen.d
java.util.ConcurrentModificationException
    at java.util.LinkedHashMap$LinkedHashIterator.nextNode(Unknown Source)
    at java.util.LinkedHashMap$LinkedKeyIterator.next(Unknown Source)
    at com.jumpmind.symmetric.console.ui.screen.a.k.a(NodeStatusPanel.java:208)
    at com.jumpmind.symmetric.console.ui.screen.d.onBackgroundDataRefresh(DashboardScreen.java:97)
    at com.jumpmind.symmetric.console.ui.a.a(BackgroundRefresherService.java:97)
    at com.jumpmind.symmetric.console.ui.a$3.run(BackgroundRefresherService.java:140)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

Relationships

duplicate of 0003678 closedmmichalek ConcurrentModification on dashboards sometimes 

Activities

hanes

2018-10-10 08:38

developer   ~0001264

Most likely fixed via changes done for issue 3678.

Issue History

Date Modified Username Field Change
2018-05-14 16:58 mmichalek New Issue
2018-10-10 08:38 hanes Assigned To => hanes
2018-10-10 08:38 hanes Status new => closed
2018-10-10 08:38 hanes Resolution open => no change required
2018-10-10 08:38 hanes Note Added: 0001264
2018-10-10 08:38 hanes Relationship added duplicate of 0003678