View Issue Details

IDProjectCategoryView StatusLast Update
0003607SymmetricDSBugpublic2018-10-17 11:51
ReporterlindomAssigned To 
Priorityurgent 
Status closedResolutionduplicate 
Product Version3.7.34 
Target VersionFixed in Version 
Summary0003607: file trigger error
DescriptionI don't know whether it's a bug or a config error.When I insert some config sql to database,this problems will appear to me .The error description is "Could not find a trigger router with a trigger_id of null and a router_id of null. The file snapshot will not be routed"
I will list my sqls below.
Steps To Reproduce-- 建立路由器,已有则不用
insert into sym_router
(router_id,source_node_group_id,target_node_group_id,router_type,create_time,last_update_time)
values('dept_2_collection_WJSB', 'dept', 'collection', 'default',current_timestamp, current_timestamp);
-- 建立通道
insert into sym_channel
(channel_id, processing_order, max_batch_size, enabled, description)
values('WJSB_200_100_file', 1, 100000, 1, 'which table you want to etl');
-- 建立重载通道
insert into sym_channel
(channel_id, processing_order, max_batch_size, enabled, description)
values('WJSB_200_100_file_reload', 1, 100000, 1, 'which table you want to etl');
-- 建立触发器
insert into sym_file_trigger
(trigger_id,channel_id,reload_channel_id,base_dir,recurse,create_time,last_update_time)
values('200_file_test','WJSB_200_100_file','WJSB_200_100_file_reload','/usr/local/symmetric/source',1,current_timestamp,current_timestamp)
-- 建立触发器和路由关系
insert into sym_file_trigger_router
(trigger_id,router_id,target_base_dir,create_time,last_update_time)
values('200_file_test','dept_2_collection','/usr/local/symmetric/destination',current_timestamp,current_timestamp)

Relationships

duplicate of 0003109 confirmed File replication routing job fails with error message when channel is not a file sync channel - needs better error message 

Activities

abrougher

2018-06-20 12:29

developer   ~0001210

Version 3.7.34 is pretty old at this point. You may want to try using the latest version.

I did notice your channel inserts do not set the FILE_SYNC_FLAG.

Is there a stack trace or any more information in your log file?

lindom

2018-06-20 23:25

reporter   ~0001211

thank you for your reply.
I set the FILE_SYNC_FLAG to "1",but it doesn't work.
I will change the version and use the latest version today.Can you give me your email?I alsohave some confusion about source code and implementation principle.

Issue History

Date Modified Username Field Change
2018-06-20 04:47 lindom New Issue
2018-06-20 12:29 abrougher Note Added: 0001210
2018-06-20 23:25 lindom Note Added: 0001211
2018-10-17 11:51 hanes Status new => closed
2018-10-17 11:51 hanes Resolution open => duplicate
2018-10-17 11:51 hanes Relationship added duplicate of 0003109