View Issue Details

IDProjectCategoryView StatusLast Update
0003630SymmetricDSBugpublic2018-08-03 10:12
ReporterafxgroupAssigned Tommichalek 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.9.9 
Target Version3.9.10Fixed in Version3.9.10 
Summary0003630: java.lang.ClassNotFoundException on com.jumpmind.symmetric.console.remote.ServerEndpoint
DescriptionI'm trying to start a newer installation of SymmetricDS but when the program starts i get this error:

java.lang.ClassNotFoundException: com.jumpmind.symmetric.console.remote.ServerEndpoint
        at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:338)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:348)
        at org.apache.commons.lang.ClassUtils.getClass(ClassUtils.java:757)
        at org.apache.commons.lang.ClassUtils.getClass(ClassUtils.java:822)
        at org.apache.commons.lang.ClassUtils.getClass(ClassUtils.java:805)
        at org.jumpmind.symmetric.SymmetricWebServer.loadRemoteStatusEndpoint(SymmetricWebServer.java:623)
        at org.jumpmind.symmetric.SymmetricWebServer.start(SymmetricWebServer.java:288)
        at org.jumpmind.symmetric.SymmetricWebServer.start(SymmetricWebServer.java:233)
        at org.jumpmind.symmetric.SymmetricWebServer.start(SymmetricWebServer.java:220)
        at org.jumpmind.symmetric.SymmetricLauncher.executeWithOptions(SymmetricLauncher.java:258)
        at org.jumpmind.symmetric.AbstractCommandLauncher.execute(AbstractCommandLauncher.java:194)
        at org.jumpmind.symmetric.SymmetricLauncher.main(SymmetricLauncher.java:83)

And indeed the two nodes are not linked
Steps To ReproduceJust run bin/sym --debug

Activities

mmichalek

2018-07-17 15:34

administrator   ~0001217

Last edited: 2018-07-18 11:58

View 2 revisions

That is a DEBUG level message and is working as designed. We recommend running at INFO level logging.

mmichalek

2018-07-18 11:56

administrator   ~0001218

Changing to not log the ClassNotFoundException, since it is expected.

Related Changesets

SymmetricDS: 3.9 59aef9b2

2018-07-18 11:56:31

mmichalek

Details Diff
0003630: java.lang.ClassNotFoundException on
com.jumpmind.symmetric.console.remote.ServerEndpoint

0003630
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/SymmetricWebServer.java Diff File

Issue History

Date Modified Username Field Change
2018-07-13 04:48 afxgroup New Issue
2018-07-17 15:34 mmichalek Note Added: 0001217
2018-07-17 15:35 mmichalek Status new => closed
2018-07-17 15:35 mmichalek Resolution open => no change required
2018-07-18 11:56 mmichalek Assigned To => mmichalek
2018-07-18 11:56 mmichalek Status closed => resolved
2018-07-18 11:56 mmichalek Resolution no change required => fixed
2018-07-18 11:56 mmichalek Fixed in Version => 3.9.10
2018-07-18 11:56 mmichalek Target Version => 3.9.10
2018-07-18 11:56 mmichalek Note Added: 0001218
2018-07-18 11:58 mmichalek Note Edited: 0001217 View Revisions
2018-07-18 12:00 mmichalek Changeset attached => SymmetricDS 3.9 59aef9b2
2018-08-03 10:12 chenson Status resolved => closed