View Issue Details

IDProjectCategoryView StatusLast Update
0003679SymmetricDSBugpublic2018-09-13 14:28
ReportermmichalekAssigned Tochenson 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.9.10 
Target Version3.9.12Fixed in Version3.9.12 
Summary0003679: Registration sometimes throws java.lang.InterruptedException
Description2018-08-16 11:00:17,702 ERROR [store-001] [RegistrationService] [store-001-job-2] Unexpected error during registration: java.lang.InterruptedException StackTraceKey.init [RuntimeException:1494018447]
java.lang.RuntimeException: java.lang.InterruptedException
    at org.jumpmind.symmetric.service.impl.TriggerRouterService.awaitTermination(TriggerRouterService.java:2234)
    at org.jumpmind.symmetric.service.impl.TriggerRouterService.updateOrCreateDatabaseTriggers(TriggerRouterService.java:1546)
    at org.jumpmind.symmetric.service.impl.TriggerRouterService.syncTriggers(TriggerRouterService.java:1215)
    at org.jumpmind.symmetric.service.impl.TriggerRouterService.syncTriggers(TriggerRouterService.java:1161)
    at org.jumpmind.symmetric.service.impl.TriggerRouterService.syncTriggers(TriggerRouterService.java:1157)
    at org.jumpmind.symmetric.load.ConfigurationChangedDatabaseWriterFilter.syncEnded(ConfigurationChangedDatabaseWriterFilter.java:331)
    at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromTransport(DataLoaderService.java:629)
    at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromPull(DataLoaderService.java:296)
    at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromPull(DataLoaderService.java:252)
    at org.jumpmind.symmetric.service.impl.RegistrationService.attemptToRegisterWithServer(RegistrationService.java:483)
    at org.jumpmind.symmetric.service.impl.RegistrationService.registerWithServer(RegistrationService.java:459)
    at org.jumpmind.symmetric.service.impl.PullService.pullData(PullService.java:89)
    at org.jumpmind.symmetric.job.PullJob.doJob(PullJob.java:48)
    at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:226)
    at org.jumpmind.symmetric.job.AbstractJob.run(AbstractJob.java:297)
    at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:54)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.InterruptedException
    at java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(AbstractQueuedSynchronizer.java:2067)
    at java.util.concurrent.ThreadPoolExecutor.awaitTermination(ThreadPoolExecutor.java:1465)
    at org.jumpmind.symmetric.service.impl.TriggerRouterService.awaitTermination(TriggerRouterService.java:2223)
    ... 22 more
2018-08-16 11:00:17,717 INFO [store-001] [RegistrationService] [store-001-job-2] We registered, but were not able to acknowledge our registration. Sending a sql event to the node where we registered to indicate that we are alive and registered
2018-08-16 11:00:17,719 ERROR [store-001] [PullJob] [store-001-job-2] Exception while executing job 'Pull' StackTraceKey.init [NullPointerException:1666781840]
java.lang.NullPointerException
    at org.jumpmind.symmetric.service.impl.DataService.insertSqlEvent(DataService.java:1179)
    at org.jumpmind.symmetric.service.impl.RegistrationService.checkRegistrationSuccessful(RegistrationService.java:539)
    at org.jumpmind.symmetric.service.impl.RegistrationService.attemptToRegisterWithServer(RegistrationService.java:525)
    at org.jumpmind.symmetric.service.impl.RegistrationService.registerWithServer(RegistrationService.java:459)
    at org.jumpmind.symmetric.service.impl.PullService.pullData(PullService.java:89)
    at org.jumpmind.symmetric.job.PullJob.doJob(PullJob.java:48)
    at org.jumpmind.symmetric.job.AbstractJob.invoke(AbstractJob.java:226)
    at org.jumpmind.symmetric.job.AbstractJob.run(AbstractJob.java:297)
    at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:54)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)

Relationships

related to 0003683 closed initial.load.create.first=true can crash the application 

Activities

mmichalek

2018-08-16 13:26

administrator  

symmetric-store-001-fail.log (91,623 bytes)

Related Changesets

SymmetricDS: 3.9 9653a358

2018-08-16 14:10:01

chenson42

Details Diff
0003679: Registration sometimes throws java.lang.InterruptedException
0003679
mod - symmetric-android/src/main/java/org/jumpmind/symmetric/android/AndroidJobManager.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/job/JobManager.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/AbstractSymmetricEngine.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/job/IJobManager.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/load/ConfigurationChangedDatabaseWriterFilter.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/route/ConfigurationChangedDataRouter.java Diff File

Issue History

Date Modified Username Field Change
2018-08-16 13:26 mmichalek New Issue
2018-08-16 13:26 mmichalek Status new => assigned
2018-08-16 13:26 mmichalek Assigned To => chenson
2018-08-16 13:26 mmichalek File Added: symmetric-store-001-fail.log
2018-08-16 13:45 mmichalek Project SymmetricDS Pro => SymmetricDS
2018-08-16 14:10 chenson Status assigned => resolved
2018-08-16 14:10 chenson Resolution open => fixed
2018-08-16 14:10 chenson Fixed in Version => 3.9.12
2018-08-16 15:00 chenson42 Changeset attached => SymmetricDS 3.9 9653a358
2018-08-16 16:30 mmichalek Target Version => 3.9.12
2018-08-20 10:52 mmichalek Status resolved => closed
2018-08-21 09:46 mmichalek Product Version 3.9.11 => 3.9.10
2018-09-13 14:28 hanes Relationship added related to 0003683