View Issue Details

IDProjectCategoryView StatusLast Update
0003733SymmetricDSImprovementpublic2018-09-24 12:00
ReporterelongAssigned Toelong 
Prioritynormal 
Status resolvedResolutionfixed 
Product Version3.9.0 
Target Version3.9.14Fixed in Version3.9.14 
Summary0003733: Logging for authorization denied
DescriptionWhen the node password doesn't match, the logging for pull and push just logs the 403 code. Log a message about authorization is denied for the node to make it clear. Don't log a big stack trace either.

On a push, the "head" request for reservation succeeds, then the "put" request fails authentication, which results in this strange error:

2018-09-21 11:08:39,389 ERROR [client-001] [DataExtractorService] [client-001-push-default-5] Failed to extract batch server-122 (org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:838))
java.lang.RuntimeException: java.io.IOException: Error writing request body to server
    at org.jumpmind.symmetric.service.impl.DataExtractorService.transferFromStaging(DataExtractorService.java:1500)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.sendOutgoingBatch(DataExtractorService.java:1358)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:764)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.extract(DataExtractorService.java:554)
    at org.jumpmind.symmetric.service.impl.PushService.pushToNode(PushService.java:203)
    at org.jumpmind.symmetric.service.impl.PushService.execute(PushService.java:165)
    at org.jumpmind.symmetric.service.impl.NodeCommunicationService$1.run(NodeCommunicationService.java:519)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: Error writing request body to server
    at sun.net.www.protocol.http.HttpURLConnection$StreamingOutputStream.checkError(HttpURLConnection.java:3465)
    at sun.net.www.protocol.http.HttpURLConnection$StreamingOutputStream.write(HttpURLConnection.java:3448)
    at sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:221)
    at sun.nio.cs.StreamEncoder.implFlushBuffer(StreamEncoder.java:291)
    at sun.nio.cs.StreamEncoder.implFlush(StreamEncoder.java:295)
    at sun.nio.cs.StreamEncoder.flush(StreamEncoder.java:141)
    at java.io.OutputStreamWriter.flush(OutputStreamWriter.java:229)
    at java.io.BufferedWriter.flush(BufferedWriter.java:254)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.transferFromStaging(DataExtractorService.java:1423)

Change the order of interceptors to be the AuthenticationInterceptor first, then NodeConcurrencyInterceptor.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.9 4826ff42

2018-09-21 10:41:17

admin

Details Diff
0003733: Logging for authorization denied
0003733
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataLoaderService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/transport/http/HttpIncomingTransport.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/transport/http/HttpOutgoingTransport.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/web/WebConstants.java Diff File

SymmetricDS: 3.9 f7914da9

2018-09-21 13:19:08

admin

Details Diff
0003733: Logging for authorization denied
0003733
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/ServerSymmetricEngine.java Diff File

SymmetricDS: 3.9 47ee3cff

2018-09-24 11:27:21

admin

Details Diff
0003733: Logging for authorization denied
0003733
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/web/AuthenticationInterceptor.java Diff File

Issue History

Date Modified Username Field Change
2018-09-21 10:40 elong New Issue
2018-09-21 10:40 elong Status new => assigned
2018-09-21 10:40 elong Assigned To => elong
2018-09-21 11:00 admin Changeset attached => SymmetricDS 3.9 4826ff42
2018-09-21 11:10 elong Description Updated View Revisions
2018-09-21 13:20 elong Status assigned => resolved
2018-09-21 13:20 elong Resolution open => fixed
2018-09-21 13:20 elong Fixed in Version => 3.9.14
2018-09-21 14:00 admin Changeset attached => SymmetricDS 3.9 f7914da9
2018-09-24 12:00 admin Changeset attached => SymmetricDS 3.9 47ee3cff