View Issue Details

IDProjectCategoryView StatusLast Update
0003978SymmetricDSBugpublic2019-06-25 14:06
Reporteruser606Assigned Touser606 
Prioritylow 
Status closedResolutionfixed 
Product Version3.10.2 
Target VersionFixed in Version3.10.3 
Summary0003978: SQLAnywhere will not create engine when database name contains hyphen
Description2019-05-28 09:23:10,738 INFO [server] [JdbcDatabasePlatformFactory] [background-refresher-1] Detected database 'SQL Anywhere', version '16', protocol 'sybase'
2019-05-28 09:23:10,750 INFO [server] [JdbcDatabasePlatformFactory] [background-refresher-1] The IDatabasePlatform being used is org.jumpmind.db.platform.sqlanywhere.SqlAnywhereDatabasePlatform
2019-05-28 09:23:10,861 INFO [server] [SqlAnywhereSymmetricDialect] [background-refresher-1] The DbDialect being used is org.jumpmind.symmetric.db.sqlanywhere.SqlAnywhereSymmetricDialect
2019-05-28 09:23:10,947 INFO [server] [AbstractSymmetricEngine] [background-refresher-1] Stopping SymmetricDS externalId=server version=development database=SQL Anywhere
2019-05-28 09:23:10,948 ERROR [server] [SymmetricEngineHolder] [background-refresher-1] (org.jumpmind.symmetric.web.SymmetricEngineHolder.create(SymmetricEngineHolder.java:304))
org.jumpmind.db.sql.SqlException: SQL Anywhere Error -131: Syntax error near 'with' on line 1
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:302)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:291)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:513)
    at org.jumpmind.db.platform.AbstractJdbcDdlReader.getSchemaNames(AbstractJdbcDdlReader.java:1512)
    at org.jumpmind.db.platform.AbstractDatabasePlatform.readTableFromDatabase(AbstractDatabasePlatform.java:279)
    at org.jumpmind.db.platform.AbstractDatabasePlatform.getTableFromCache(AbstractDatabasePlatform.java:330)
    at org.jumpmind.db.platform.AbstractDatabasePlatform.getTableFromCache(AbstractDatabasePlatform.java:318)
    at org.jumpmind.symmetric.service.impl.ExtensionService.refresh(ExtensionService.java:95)
    at org.jumpmind.symmetric.service.impl.ClientExtensionService.refresh(ClientExtensionService.java:46)
    at org.jumpmind.symmetric.AbstractSymmetricEngine.init(AbstractSymmetricEngine.java:342)
    at org.jumpmind.symmetric.ClientSymmetricEngine.init(ClientSymmetricEngine.java:202)
    at org.jumpmind.symmetric.web.ServerSymmetricEngine.init(ServerSymmetricEngine.java:80)
    at org.jumpmind.symmetric.ClientSymmetricEngine.<init>(ClientSymmetricEngine.java:158)
    at org.jumpmind.symmetric.web.ServerSymmetricEngine.<init>(ServerSymmetricEngine.java:59)
    at org.jumpmind.symmetric.web.SymmetricEngineHolder.create(SymmetricEngineHolder.java:284)
    at org.jumpmind.symmetric.web.SymmetricEngineHolder.install(SymmetricEngineHolder.java:428)
    at com.jumpmind.symmetric.console.ui.wizard.setup.AbstractWizardScreen.install(AbstractWizardScreen.java:170)
    at com.jumpmind.symmetric.console.ui.wizard.setup.SummaryScreen$InstallWorker.doWork(SummaryScreen.java:68)
    at com.jumpmind.symmetric.console.ui.common.InProgressDialog$2.onBackgroundDataRefresh(InProgressDialog.java:99)
    at com.jumpmind.symmetric.console.ui.BackgroundRefresherService.refresh(BackgroundRefresherService.java:99)
    at com.jumpmind.symmetric.console.ui.BackgroundRefresherService$3.run(BackgroundRefresherService.java:142)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.sql.SQLException: SQL Anywhere Error -131: Syntax error near 'with' on line 1
    at com.sybase.jdbc4.jdbc.SybConnection.getAllExceptions(SybConnection.java:2780)
    at com.sybase.jdbc4.jdbc.SybStatement.handleSQLE(SybStatement.java:2665)
    at com.sybase.jdbc4.jdbc.SybStatement.nextResult(SybStatement.java:295)
    at com.sybase.jdbc4.jdbc.SybStatement.nextResult(SybStatement.java:272)
    at com.sybase.jdbc4.jdbc.SybStatement.queryLoop(SybStatement.java:2409)
    at com.sybase.jdbc4.jdbc.SybCallableStatement.executeQuery(SybCallableStatement.java:147)
    at com.sybase.jdbc4.jdbc.SybDatabaseMetaData.returnResults(SybDatabaseMetaData.java:4286)
    at com.sybase.jdbc4.jdbc.SybDatabaseMetaData.getSchemas(SybDatabaseMetaData.java:4515)
    at com.sybase.jdbc4.jdbc.SybDatabaseMetaData.getSchemas(SybDatabaseMetaData.java:3080)
    at org.apache.commons.dbcp.DelegatingDatabaseMetaData.getSchemas(DelegatingDatabaseMetaData.java:522)
    at org.jumpmind.db.platform.AbstractJdbcDdlReader$6.execute(AbstractJdbcDdlReader.java:1523)
    at org.jumpmind.db.platform.AbstractJdbcDdlReader$6.execute(AbstractJdbcDdlReader.java:1)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:511)
    ... 25 more
2019-05-28 09:23:10,982 WARN [server] [SymmetricEngineHolder] [background-refresher-1] The engine could not be created. It will not be started (org.jumpmind.symmetric.web.SymmetricEngineHolder.install(SymmetricEngineHolder.java:433))
2019-05-28 09:23:10,983 ERROR [server] [BackgroundRefresherService] [background-refresher-1] Exception while refreshing class com.jumpmind.symmetric.console.ui.common.InProgressDialog$2 (com.jumpmind.symmetric.console.ui.BackgroundRefresherService.refresh(BackgroundRefresherService.java:128))
java.lang.RuntimeException: The installation of the node failed. Please check the log files for details about the failure.
    at com.jumpmind.symmetric.console.ui.wizard.setup.AbstractWizardScreen.install(AbstractWizardScreen.java:183)
    at com.jumpmind.symmetric.console.ui.wizard.setup.SummaryScreen$InstallWorker.doWork(SummaryScreen.java:68)
    at com.jumpmind.symmetric.console.ui.common.InProgressDialog$2.onBackgroundDataRefresh(InProgressDialog.java:99)
    at com.jumpmind.symmetric.console.ui.BackgroundRefresherService.refresh(BackgroundRefresherService.java:99)
    at com.jumpmind.symmetric.console.ui.BackgroundRefresherService$3.run(BackgroundRefresherService.java:142)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(Unknown Source)
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Steps To ReproduceCreate db with hyphen and try to create node
Additional InformationDB Name: with-special
Tagsdialect: sql anywhere

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.10 527938b3

2019-05-28 11:10:58

jfrees

Details Diff
0003978: SQLAnywhere will not create engine when database name contains
hyphen

0003978
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/AbstractJdbcDdlReader.java Diff File

SymmetricDS: 3.10 9e5a2660

2019-05-28 11:44:29

jfrees

Details Diff
0003978: SQLAnywhere will not create engine when database name contains
hyphen

Same error on metaData.getSchema() method, but different spot.

0003978
mod - symmetric-sqlexplorer/src/main/java/org/jumpmind/vaadin/ui/sqlexplorer/DatabaseInfoPanel.java Diff File

Issue History

Date Modified Username Field Change
2019-05-28 09:25 user606 New Issue
2019-05-28 09:25 user606 Status new => assigned
2019-05-28 09:25 user606 Assigned To => user606
2019-05-28 09:29 user606 Project SymmetricDS Pro => SymmetricDS
2019-05-28 10:09 user606 Tag Attached: dialect: sql anywhere
2019-05-28 11:14 user606 Status assigned => resolved
2019-05-28 11:14 user606 Resolution open => fixed
2019-05-28 11:14 user606 Fixed in Version => 3.10.3
2019-05-28 12:00 jfrees Changeset attached => SymmetricDS 3.10 9e5a2660
2019-05-28 12:00 jfrees Changeset attached => SymmetricDS 3.10 527938b3
2019-06-25 14:06 admin Status resolved => closed