View Issue Details

IDProjectCategoryView StatusLast Update
0004035SymmetricDSBugpublic2019-07-05 12:00
ReporterelongAssigned Toelong 
Prioritynormal 
Status resolvedResolutionfixed 
Product Version3.10.0 
Target Version3.10.4Fixed in Version3.10.4 
Summary0004035: Firebird 3 gets wrong dialect, errors on sym_escape
DescriptionThe Firebird version 3 database is getting the based FirebirdDialect, which is meant for pre-2.0 version of Firebird. The if-else structure that creates the Firebird dialect does not account for newer versions. It should return the Firebird21SymmetricDialect for version 2.1 and newer of Firebird.
Tagsdialect: firebird

Activities

elong

2019-07-05 10:23

developer   ~0001550

Attaching patch to fix.

patch-0004035.jar (2,682 bytes)

Related Changesets

SymmetricDS: 3.10 1fe5b420

2019-07-05 10:25:53

admin

Details Diff
0004035: Firebird 3 gets wrong dialect, errors on sym_escape
0004035
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/JdbcSymmetricDialectFactory.java Diff File

Issue History

Date Modified Username Field Change
2019-07-05 10:17 elong New Issue
2019-07-05 10:17 elong Status new => assigned
2019-07-05 10:17 elong Assigned To => elong
2019-07-05 10:23 elong File Added: patch-0004035.jar
2019-07-05 10:23 elong Note Added: 0001550
2019-07-05 11:07 elong Tag Attached: dialect: firebird
2019-07-05 11:07 elong Status assigned => resolved
2019-07-05 11:07 elong Resolution open => fixed
2019-07-05 11:07 elong Fixed in Version => 3.10.4
2019-07-05 12:00 admin Changeset attached => SymmetricDS 3.10 1fe5b420