View Issue Details

IDProjectCategoryView StatusLast Update
0004076SymmetricDSBugpublic2019-08-23 12:46
ReporterpmarzulloAssigned Topmarzullo 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.10.3 
Target Version3.10.4Fixed in Version3.10.4 
Summary0004076: Get estimated row counts for initial load for SQL Server 2008 needs to use delimiter quoting if turned on
DescriptionMsSql2008DatabasePlatform.getEstimatedRowCount(Table table)

Should use quoting for the catalog if it is turned on.
Steps To Reproduce1. Create database with a dash ("-") in the catalog name for SQL Server 2008
2. Do an initial load for SQL Server 2008
3. Initial load will always fail because of the above method not quoting the catalog.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.10 1d94f77f

2019-08-22 09:50:38

Philip Marzullo

Details Diff
0004076: Get estimated row counts for initial load for SQL Server 2008
needs to use delimiter quoting if turned on

0004076
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/mssql/MsSql2008DatabasePlatform.java Diff File

Issue History

Date Modified Username Field Change
2019-08-22 09:45 pmarzullo New Issue
2019-08-22 09:45 pmarzullo Status new => assigned
2019-08-22 09:45 pmarzullo Assigned To => pmarzullo
2019-08-22 09:51 pmarzullo Status assigned => resolved
2019-08-22 09:51 pmarzullo Resolution open => fixed
2019-08-22 09:51 pmarzullo Fixed in Version => 3.10.4
2019-08-22 10:00 Changeset attached => SymmetricDS 3.10 1d94f77f
2019-08-23 12:46 admin Status resolved => closed