View Issue Details

IDProjectCategoryView StatusLast Update
0004137SymmetricDSBugpublic2019-11-01 08:44
ReporterpmarzulloAssigned Topmarzullo 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.10.5 
Target Version3.10.5Fixed in Version3.10.5 
Summary0004137: Initial load table with 0 rows doesn't close off all estimated batches
DescriptionWhen an initial load request for a table is requested for a node, the estimated number of rows just counts the number of rows in the table to create the expected number of batches.

When it is a table that has 0 rows intended for the node, then the first batch is finished off, but the rest of the created batches stay in the status of requested (RQ), and synching stops for the initial load and the node.
Steps To Reproduce1. Request table to synch to a node that has more rows than the configured number of rows per batch in the channel configuration.
2. The rows should not be intended for the node.

Results:
Batches created and set to RQ status.
Extractor extracts 0 rows, and sets first batch to NE.
Rest of batches remain in RQ status, and Data Extractor waits indefinitely for batches to move to new (NE) status.
Tagsinitial/partial load

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.10 9859752d

2019-10-31 10:04:09

Philip Marzullo

Details Diff
0004137: Initial load table with 0 rows doesn't close off all estimated
batches

0004137
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/MultiBatchStagingWriter.java Diff File

Issue History

Date Modified Username Field Change
2019-10-31 10:02 pmarzullo New Issue
2019-10-31 10:02 pmarzullo Status new => assigned
2019-10-31 10:02 pmarzullo Assigned To => pmarzullo
2019-10-31 10:02 pmarzullo Tag Attached: initial/partial load
2019-10-31 10:04 pmarzullo Status assigned => resolved
2019-10-31 10:04 pmarzullo Resolution open => fixed
2019-10-31 10:04 pmarzullo Fixed in Version => 3.10.5
2019-10-31 11:00 Changeset attached => SymmetricDS 3.10 9859752d
2019-11-01 08:44 admin Status resolved => closed