View Issue Details

IDProjectCategoryView StatusLast Update
0004157SymmetricDS ProInstallationpublic2019-12-02 15:10
Reportergilles.riandAssigned Topmarzullo 
Priorityhigh 
Status closedResolutionfixed 
Product Version3.11.0 
Target Version3.11.1Fixed in Version3.11.1 
Summary0004157: Impossible to see the webconsole (version pro) with Interbase
DescriptionThe web console is empty and in the log I have some strange errors.... Like if the queries are not valid for display the webconsole

Steps To ReproduceJust install SYMDS 3.11.0 or 3.10.6 (it's the same error) on a INTERBASE XE, 2017 etc...

After Install and login >>>>> The webconsole is empty !!!



Additional Information2019-11-22 12:16:33,520 INFO [server] [NodeCommunicationService] [server-job-3] pull will use 10 threads
2019-11-22 12:16:33,520 INFO [server] [DataService] [server-job-1] Inserting missing last data gap: { startId: 1, endId: 50000001, createTime: "Fri Nov 22 12:16:33 CET 2019" }
2019-11-22 12:16:33,707 INFO [server] [DataGapFastDetector] [server-job-1] Full gap analysis is running
2019-11-22 12:16:33,707 INFO [server] [DataGapFastDetector] [server-job-1] Querying data in gaps from database took 0 ms
2019-11-22 12:16:33,707 INFO [server] [DataGapFastDetector] [server-job-1] Full gap analysis is done after 0 ms
2019-11-22 12:16:34,051 INFO [server] [ConfigurationChangedDataRouter] [server-job-1] About to refresh the cache of nodes because new configuration came through the data router
2019-11-22 12:16:34,176 INFO [server] [RouterService] [server-job-1] Routed 6 data events in 469 ms
2019-11-22 12:19:07,732 ERROR [gui] [b] [qtp24119573-32] [interclient][interbase]Dynamic SQL Error
[interclient][interbase]SQL error code = -104
[interclient][interbase]Token unknown - line 1, char 65
[interclient][interbase]type StackTraceKey.init [SqlException:1361861401]
org.jumpmind.db.sql.SqlException: [interclient][interbase]Dynamic SQL Error
[interclient][interbase]SQL error code = -104
[interclient][interbase]Token unknown - line 1, char 65
[interclient][interbase]type
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:305)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:294)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:519)
    at org.jumpmind.db.sql.JdbcSqlTemplate.update(JdbcSqlTemplate.java:358)
    at org.jumpmind.db.sql.AbstractSqlTemplate.update(AbstractSqlTemplate.java:227)
    at com.jumpmind.symmetric.console.service.impl.ProConsoleService.createSystemMonitors(ProConsoleService.java:82)
    at com.jumpmind.symmetric.console.ui.b.initializeTabs(MainWindow.java:627)
    at com.jumpmind.symmetric.console.impl.bs.b(LicenseKeyEditPanel.java:182)
    at com.jumpmind.symmetric.console.impl.bs.a(LicenseKeyEditPanel.java:30)
    at com.jumpmind.symmetric.console.impl.bs$3.buttonClick(LicenseKeyEditPanel.java:322)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:499)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:273)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:237)
    at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1014)
    at com.vaadin.ui.Button.fireClick(Button.java:384)
    at com.vaadin.ui.Button$1.click(Button.java:57)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:155)
    at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:116)
    at com.vaadin.server.communication.ServerRpcHandler.handleInvocation(ServerRpcHandler.java:445)
    at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:410)
    at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:274)
    at com.vaadin.server.communication.PushHandler.lambda$new$1(PushHandler.java:148)
    at com.vaadin.server.communication.PushHandler.callWithUi(PushHandler.java:248)
    at com.vaadin.server.communication.PushHandler.onMessage(PushHandler.java:534)
    at com.vaadin.server.communication.PushAtmosphereHandler.onMessage(PushAtmosphereHandler.java:87)
    at com.vaadin.server.communication.PushAtmosphereHandler.onRequest(PushAtmosphereHandler.java:77)
    at org.atmosphere.cpr.AsynchronousProcessor.action(AsynchronousProcessor.java:225)
    at org.atmosphere.cpr.AsynchronousProcessor.suspended(AsynchronousProcessor.java:114)
    at org.atmosphere.container.Servlet30CometSupport.service(Servlet30CometSupport.java:67)
    at org.atmosphere.cpr.AtmosphereFramework.doCometSupport(AtmosphereFramework.java:2297)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:594)
    at org.atmosphere.websocket.DefaultWebSocketProcessor$3.run(DefaultWebSocketProcessor.java:345)
    at org.atmosphere.util.VoidExecutorService.execute(VoidExecutorService.java:101)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:340)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.invokeWebSocketProtocol(DefaultWebSocketProcessor.java:448)
    at org.atmosphere.container.JSR356Endpoint$3.onMessage(JSR356Endpoint.java:272)
    at org.atmosphere.container.JSR356Endpoint$3.onMessage(JSR356Endpoint.java:269)
    at org.eclipse.jetty.websocket.jsr356.messages.TextWholeMessage.messageComplete(TextWholeMessage.java:59)
    at org.eclipse.jetty.websocket.jsr356.endpoints.JsrEndpointEventDriver.onTextFrame(JsrEndpointEventDriver.java:218)
    at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.incomingFrame(AbstractEventDriver.java:150)
    at org.eclipse.jetty.websocket.common.WebSocketSession.incomingFrame(WebSocketSession.java:319)
    at org.eclipse.jetty.websocket.common.extensions.AbstractExtension.nextIncomingFrame(AbstractExtension.java:147)
    at org.eclipse.jetty.websocket.common.extensions.compress.PerMessageDeflateExtension.nextIncomingFrame(PerMessageDeflateExtension.java:112)
    at org.eclipse.jetty.websocket.common.extensions.compress.CompressExtension.forwardIncoming(CompressExtension.java:142)
    at org.eclipse.jetty.websocket.common.extensions.compress.PerMessageDeflateExtension.incomingFrame(PerMessageDeflateExtension.java:92)
    at org.eclipse.jetty.websocket.common.extensions.ExtensionStack.incomingFrame(ExtensionStack.java:201)
    at org.eclipse.jetty.websocket.common.Parser.notifyFrame(Parser.java:226)
    at org.eclipse.jetty.websocket.common.Parser.parseSingleFrame(Parser.java:260)
    at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.readParse(AbstractWebSocketConnection.java:583)
    at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onFillable(AbstractWebSocketConnection.java:441)
    at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onFillable(AbstractWebSocketConnection.java:428)
    at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:305)
    at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:103)
    at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:117)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(EatWhatYouKill.java:333)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:310)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(EatWhatYouKill.java:168)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:126)
    at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:366)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:781)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$Runner.run(QueuedThreadPool.java:917)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.sql.SQLException: [interclient][interbase]Dynamic SQL Error
[interclient][interbase]SQL error code = -104
[interclient][interbase]Token unknown - line 1, char 65
[interclient][interbase]type
    at interbase.interclient.PreparedStatement.remote_PREPARE_STATEMENT(Unknown Source)
    at interbase.interclient.PreparedStatement.<init>(Unknown Source)
    at interbase.interclient.Connection.prepareStatement(Unknown Source)
    at interbase.interclient.Connection.prepareStatement(Unknown Source)
    at org.apache.commons.dbcp.DelegatingConnection.prepareStatement(DelegatingConnection.java:281)
    at org.apache.commons.dbcp.PoolingDataSource$PoolGuardConnectionWrapper.prepareStatement(PoolingDataSource.java:313)
    at org.jumpmind.db.sql.JdbcSqlTemplate$5.execute(JdbcSqlTemplate.java:385)
    at org.jumpmind.db.sql.JdbcSqlTemplate$5.execute(JdbcSqlTemplate.java:358)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:517)
    ... 67 more
2019-11-22 12:19:14,565 INFO [server] [ConfigurationChangedDataRouter] [server-job-3] About to refresh the cache of parameters because new configuration came through the data router
2019-11-22 12:19:14,579 INFO [server] [RouterService] [server-job-3] Routed 1 data events in 198 ms
2019-11-22 12:19:17,665 ERROR [gui] [b] [qtp24119573-15] [interclient][interbase]Dynamic SQL Error
[interclient][interbase]SQL error code = -104
[interclient][interbase]Token unknown - line 1, char 65
[interclient][interbase]type StackTraceKey.init [SqlException:3933347476]
org.jumpmind.db.sql.SqlException: [interclient][interbase]Dynamic SQL Error
[interclient][interbase]SQL error code = -104
[interclient][interbase]Token unknown - line 1, char 65
[interclient][interbase]type
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:305)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:294)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:519)
    at org.jumpmind.db.sql.JdbcSqlTemplate.update(JdbcSqlTemplate.java:358)
    at org.jumpmind.db.sql.AbstractSqlTemplate.update(AbstractSqlTemplate.java:227)
    at com.jumpmind.symmetric.console.service.impl.ProConsoleService.createSystemMonitors(ProConsoleService.java:82)
    at com.jumpmind.symmetric.console.ui.b.initializeTabs(MainWindow.java:627)
    at com.jumpmind.symmetric.console.impl.bs.b(LicenseKeyEditPanel.java:182)
    at com.jumpmind.symmetric.console.impl.bs.a(LicenseKeyEditPanel.java:30)
    at com.jumpmind.symmetric.console.impl.bs$3.buttonClick(LicenseKeyEditPanel.java:322)
    at sun.reflect.GeneratedMethodAccessor53.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:499)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:273)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:237)
    at com.vaadin.server.AbstractClientConnector.fireEvent(AbstractClientConnector.java:1014)
    at com.vaadin.ui.Button.fireClick(Button.java:384)
    at com.vaadin.ui.Button$1.click(Button.java:57)
    at sun.reflect.GeneratedMethodAccessor52.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:155)
    at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:116)
    at com.vaadin.server.communication.ServerRpcHandler.handleInvocation(ServerRpcHandler.java:445)
    at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:410)
    at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:274)
    at com.vaadin.server.communication.PushHandler.lambda$new$1(PushHandler.java:148)
    at com.vaadin.server.communication.PushHandler.callWithUi(PushHandler.java:248)
    at com.vaadin.server.communication.PushHandler.onMessage(PushHandler.java:534)
    at com.vaadin.server.communication.PushAtmosphereHandler.onMessage(PushAtmosphereHandler.java:87)
    at com.vaadin.server.communication.PushAtmosphereHandler.onRequest(PushAtmosphereHandler.java:77)
    at org.atmosphere.cpr.AsynchronousProcessor.action(AsynchronousProcessor.java:225)
    at org.atmosphere.cpr.AsynchronousProcessor.suspended(AsynchronousProcessor.java:114)
    at org.atmosphere.container.Servlet30CometSupport.service(Servlet30CometSupport.java:67)
    at org.atmosphere.cpr.AtmosphereFramework.doCometSupport(AtmosphereFramework.java:2297)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:594)
    at org.atmosphere.websocket.DefaultWebSocketProcessor$3.run(DefaultWebSocketProcessor.java:345)
    at org.atmosphere.util.VoidExecutorService.execute(VoidExecutorService.java:101)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.dispatch(DefaultWebSocketProcessor.java:340)
    at org.atmosphere.websocket.DefaultWebSocketProcessor.invokeWebSocketProtocol(DefaultWebSocketProcessor.java:448)
    at org.atmosphere.container.JSR356Endpoint$3.onMessage(JSR356Endpoint.java:272)
    at org.atmosphere.container.JSR356Endpoint$3.onMessage(JSR356Endpoint.java:269)
    at org.eclipse.jetty.websocket.jsr356.messages.TextWholeMessage.messageComplete(TextWholeMessage.java:59)
    at org.eclipse.jetty.websocket.jsr356.endpoints.JsrEndpointEventDriver.onTextFrame(JsrEndpointEventDriver.java:218)
    at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.incomingFrame(AbstractEventDriver.java:150)
    at org.eclipse.jetty.websocket.common.WebSocketSession.incomingFrame(WebSocketSession.java:319)
    at org.eclipse.jetty.websocket.common.extensions.AbstractExtension.nextIncomingFrame(AbstractExtension.java:147)
    at org.eclipse.jetty.websocket.common.extensions.compress.PerMessageDeflateExtension.nextIncomingFrame(PerMessageDeflateExtension.java:112)
    at org.eclipse.jetty.websocket.common.extensions.compress.CompressExtension.forwardIncoming(CompressExtension.java:142)
    at org.eclipse.jetty.websocket.common.extensions.compress.PerMessageDeflateExtension.incomingFrame(PerMessageDeflateExtension.java:92)
    at org.eclipse.jetty.websocket.common.extensions.ExtensionStack.incomingFrame(ExtensionStack.java:201)
    at org.eclipse.jetty.websocket.common.Parser.notifyFrame(Parser.java:226)
    at org.eclipse.jetty.websocket.common.Parser.parseSingleFrame(Parser.java:260)
    at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.readParse(AbstractWebSocketConnection.java:583)
    at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onFillable(AbstractWebSocketConnection.java:441)
    at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onFillable(AbstractWebSocketConnection.java:428)
    at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:305)
    at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:103)
    at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:117)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(EatWhatYouKill.java:333)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:310)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(EatWhatYouKill.java:168)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:126)
    at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:366)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:781)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$Runner.run(QueuedThreadPool.java:917)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.sql.SQLException: [interclient][interbase]Dynamic SQL Error
[interclient][interbase]SQL error code = -104
[interclient][interbase]Token unknown - line 1, char 65
[interclient][interbase]type
    at interbase.interclient.PreparedStatement.remote_PREPARE_STATEMENT(Unknown Source)
    at interbase.interclient.PreparedStatement.<init>(Unknown Source)
    at interbase.interclient.Connection.prepareStatement(Unknown Source)
    at interbase.interclient.Connection.prepareStatement(Unknown Source)
    at org.apache.commons.dbcp.DelegatingConnection.prepareStatement(DelegatingConnection.java:281)
    at org.apache.commons.dbcp.PoolingDataSource$PoolGuardConnectionWrapper.prepareStatement(PoolingDataSource.java:313)
    at org.jumpmind.db.sql.JdbcSqlTemplate$5.execute(JdbcSqlTemplate.java:385)
    at org.jumpmind.db.sql.JdbcSqlTemplate$5.execute(JdbcSqlTemplate.java:358)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:517)
    ... 65 more
2019-11-22 12:19:24,757 INFO [server] [ConfigurationChangedDataRouter] [server-job-19] About to refresh the cache of parameters because new configuration came through the data router
2019-11-22 12:19:24,770 INFO [server] [RouterService] [server-job-19] Routed 1 data events in 160 ms
2019-11-22 12:28:21,947 ERROR [gui] [b] [qtp24119573-295] [interclient][interbase]Dynamic SQL Error
[interclient][interbase]SQL error code = -104
[interclient][interbase]Token unknown - line 1, char 65
[interclient][interbase]type StackTraceKey [SqlException:3933347476]
2019-11-22 12:28:25,522 INFO [server] [ConfigurationChangedDataRouter] [server-job-16] About to refresh the cache of parameters because new configuration came through the data router
2019-11-22 12:28:25,534 INFO [server] [RouterService] [server-job-16] Routed 1 data events in 274 ms
Tagsdialect: interbase

Activities

gilles.riand

2019-11-22 06:40

reporter  

gilles.riand

2019-11-22 06:59

reporter   ~0001645

I think these queries are strange ... the variables are really defined?

select distinct channel_id from sym_data where ((data_id between 5.04403158265496E+17 and 2263939586));


/* 22/11/2019 12:19:14 */
/* QrID=156175 TrID=152958; EXECUTE */
delete from sym_data_gap where start_id=5.04403158265496E+17 and end_id=2263939586;

gilles.riand

2019-11-22 09:05

reporter   ~0001646

I think it's a problem with "TYPE" FIELD in SYM_MONITOR and SYM_MONITOR_EVENT

https://www.symmetricds.org/issues/view.php?id=3834

I tested with postgresql and the DDL of table aren't the same

CREATE TABLE public.sym_monitor
(
  monitor_id character varying(128) NOT NULL,
  node_group_id character varying(50) NOT NULL DEFAULT 'ALL'::character varying,
  external_id character varying(255) NOT NULL DEFAULT 'ALL'::character varying,
  type character varying(50) NOT NULL,
  expression text,
  threshold bigint NOT NULL DEFAULT 0,
  run_period integer NOT NULL DEFAULT 0,
  run_count integer NOT NULL DEFAULT 0,
  severity_level integer NOT NULL DEFAULT 0,
  enabled smallint NOT NULL DEFAULT 0,
  create_time timestamp without time zone,
  last_update_by character varying(50),
  last_update_time timestamp without time zone,
  CONSTRAINT sym_monitor_pkey PRIMARY KEY (monitor_id)
)
WITH (
  OIDS=FALSE
);
ALTER TABLE public.sym_monitor
  OWNER TO postgres;


and for INTERBASE it's

CREATE TABLE SYM_MONITOR (
    MONITOR_ID VARCHAR(128) NOT NULL,
    NODE_GROUP_ID VARCHAR(50) DEFAULT 'ALL' NOT NULL,
    EXTERNAL_ID VARCHAR(255) DEFAULT 'ALL' NOT NULL,
    "TYPE" VARCHAR(50) NOT NULL,
    EXPRESSION VARCHAR(3840),
    THRESHOLD NUMERIC(18,0) DEFAULT 0 NOT NULL,
    RUN_PERIOD INTEGER DEFAULT 0 NOT NULL,
    RUN_COUNT INTEGER DEFAULT 0 NOT NULL,
    SEVERITY_LEVEL INTEGER DEFAULT 0 NOT NULL,
    ENABLED SMALLINT DEFAULT 0 NOT NULL,
    CREATE_TIME TIMESTAMP,
    LAST_UPDATE_BY VARCHAR(50),
    LAST_UPDATE_TIME TIMESTAMP
);

pmarzullo

2019-11-22 11:18

developer   ~0001648

Wrap column named 'type' with delimiter when querying.

Issue History

Date Modified Username Field Change
2019-11-22 06:40 gilles.riand New Issue
2019-11-22 06:40 gilles.riand File Added: 2019-11-22 12_39_48-server - SymmetricDS Pro.png
2019-11-22 06:59 gilles.riand Note Added: 0001645
2019-11-22 09:05 gilles.riand Note Added: 0001646
2019-11-22 11:15 pmarzullo Assigned To => pmarzullo
2019-11-22 11:15 pmarzullo Status new => assigned
2019-11-22 11:16 pmarzullo Tag Attached: dialect: interbase
2019-11-22 11:17 pmarzullo Target Version => 3.11.1
2019-11-22 11:17 pmarzullo Description Updated View Revisions
2019-11-22 11:17 pmarzullo Steps to Reproduce Updated View Revisions
2019-11-22 11:17 pmarzullo Additional Information Updated View Revisions
2019-11-22 11:18 pmarzullo Status assigned => resolved
2019-11-22 11:18 pmarzullo Resolution open => fixed
2019-11-22 11:18 pmarzullo Fixed in Version => 3.11.1
2019-11-22 11:18 pmarzullo Note Added: 0001648
2019-12-02 15:10 admin Status resolved => closed