View Issue Details

IDProjectCategoryView StatusLast Update
0004269SymmetricDSBugpublic2020-02-14 12:45
ReporterpmarzulloAssigned Topmarzullo 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.11.4 
Target Version3.11.5Fixed in Version3.11.5 
Summary0004269: Multi-master configuration with 3 nodes doesn't work
DescriptionMulti-master configuration with 3 nodes doesn't work. Periodic 1 second report to console:

[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed

=======
After some time the error changes to:

[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
java.net.SocketException: Software caused connection abort: recv failed
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.socketRead(Unknown Source)
        at java.net.SocketInputStream.read(Unknown Source)
        at java.net.SocketInputStream.read(Unknown Source)
        at java.io.BufferedInputStream.fill(Unknown Source)
        at java.io.BufferedInputStream.read1(Unknown Source)
        at java.io.BufferedInputStream.read(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
        at java.net.HttpURLConnection.getResponseCode(Unknown Source)
        at org.jumpmind.symmetric.transport.http.HttpOutgoingTransport.readResponse(HttpOutgoingTransport.java:320)
        at com.jumpmind.symmetric.console.remote.m.readResponse(RemoteStatusHttpOutgoingTransport.java:62)
        at org.jumpmind.symmetric.service.impl.AbstractService.readAcks(AbstractService.java:295)
        at org.jumpmind.symmetric.service.impl.PushService.pushToNode(PushService.java:211)
        at org.jumpmind.symmetric.service.impl.PushService.execute(PushService.java:167)
        at org.jumpmind.symmetric.service.impl.NodeCommunicationService$1.run(NodeCommunicationService.java:517)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
java.net.SocketException: Software caused connection abort: recv failed
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.socketRead(Unknown Source)
        at java.net.SocketInputStream.read(Unknown Source)
        at java.net.SocketInputStream.read(Unknown Source)
Steps To Reproduce1) Fresh SymmetricDS pro installation
2) Create Master node with H2 database and table DB1
3) Create Local Node with H2 database and table DB2
4) Create Local Node with H2 database and table DB3

... or sample configuration included
Tagsregistration

Relationships

related to 0004254 closedpmarzullo Multi-master configuration with 3 nodes doesn't work 

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.11 c6c70b5a

2020-01-31 10:54:58

Philip Marzullo

Details Diff
0004269: Multi-master configuration with 3 nodes doesn't work
0004269
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/IParameterService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/InitialLoadService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/ParameterService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/PushService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RegistrationService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/TriggerRouterService.java Diff File
mod - symmetric-core/src/test/java/org/jumpmind/symmetric/service/impl/MockParameterService.java Diff File

Issue History

Date Modified Username Field Change
2020-01-31 10:50 pmarzullo New Issue
2020-01-31 10:50 pmarzullo Status new => assigned
2020-01-31 10:50 pmarzullo Assigned To => pmarzullo
2020-01-31 10:50 pmarzullo Tag Attached: registration
2020-01-31 10:51 pmarzullo Relationship added related to 0004254
2020-01-31 10:55 pmarzullo Status assigned => resolved
2020-01-31 10:55 pmarzullo Resolution open => fixed
2020-01-31 10:55 pmarzullo Fixed in Version => 3.11.5
2020-01-31 11:00 Changeset attached => SymmetricDS 3.11 c6c70b5a
2020-02-14 12:45 elong Status resolved => closed