View Issue Details

IDProjectCategoryView StatusLast Update
0004328SymmetricDS ProBugpublic2020-03-25 15:40
ReporterpmarzulloAssigned Topmarzullo 
Prioritynormal 
Status resolvedResolutionfixed 
Product Version3.11.5 
Target Version3.11.8Fixed in Version3.11.8 
Summary0004328: Servlet filter needs to be created with async-supported enabled
DescriptionFor the Console servlet, the servlet is configured with async-supported enabled.
The filter (LogRequestResponseFilter) also needs async-supported enabled.

Otherwise errors like this occur when you log in remotely:
2020-03-25 13:32:59,580 WARN [gui] [HttpChannel] [qtp68377659-16] /app/PUSH StackTraceKey.init [ServletException:1498245785]
javax.servlet.ServletException: com.vaadin.server.ServiceException: java.lang.IllegalStateException: !asyncSupported: LogRequestResponseFilter@290df792==org.jumpmind.symmetric.web.LogRequestResponseFilter,inst=true,async=false
    at com.vaadin.server.VaadinServlet.service(VaadinServlet.java:447)
    at com.jumpmind.symmetric.console.ui.AppServlet.service(AppServlet.java:41)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:876)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1623)
    at org.jumpmind.symmetric.web.LogRequestResponseFilter.doFilter(LogRequestResponseFilter.java:53)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1602)
    at org.eclipse.jetty.websocket.server.WebSocketUpgradeFilter.doFilter(WebSocketUpgradeFilter.java:214)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at org.jumpmind.symmetric.web.HttpMethodFilter.doFilter(HttpMethodFilter.java:62)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1610)
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:540)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:146)
    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:548)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:132)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:257)
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:1711)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:255)
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1347)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:203)
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:480)
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:1678)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:201)
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1249)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:144)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:132)
    at org.eclipse.jetty.server.Server.handle(Server.java:505)
    at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:370)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:267)
    at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:305)
    at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:103)
    at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:117)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(EatWhatYouKill.java:333)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:310)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(EatWhatYouKill.java:168)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:126)
    at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:366)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:781)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$Runner.run(QueuedThreadPool.java:917)
    at java.lang.Thread.run(Thread.java:748)
Caused by: com.vaadin.server.ServiceException: java.lang.IllegalStateException: !asyncSupported: LogRequestResponseFilter@290df792==org.jumpmind.symmetric.web.LogRequestResponseFilter,inst=true,async=false
    at com.vaadin.server.VaadinService.handleExceptionDuringRequest(VaadinService.java:1654)
    at com.vaadin.server.VaadinService.handleRequest(VaadinService.java:1614)
    at com.vaadin.server.VaadinServlet.service(VaadinServlet.java:445)
    ... 39 more
Caused by: java.lang.IllegalStateException: !asyncSupported: LogRequestResponseFilter@290df792==org.jumpmind.symmetric.web.LogRequestResponseFilter,inst=true,async=false
    at org.eclipse.jetty.server.Request.startAsync(Request.java:2273)
    at javax.servlet.ServletRequestWrapper.startAsync(ServletRequestWrapper.java:464)
    at org.atmosphere.cpr.AtmosphereRequestImpl.startAsync(AtmosphereRequestImpl.java:633)
    at org.atmosphere.container.Servlet30CometSupport.suspend(Servlet30CometSupport.java:94)
    at org.atmosphere.container.Servlet30CometSupport.service(Servlet30CometSupport.java:69)
    at org.atmosphere.cpr.AtmosphereFramework.doCometSupport(AtmosphereFramework.java:2297)
    at com.vaadin.server.communication.PushRequestHandler.handleRequest(PushRequestHandler.java:234)
    at com.vaadin.server.VaadinService.handleRequest(VaadinService.java:1602)
    ... 40 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-03-25 14:59 pmarzullo New Issue
2020-03-25 14:59 pmarzullo Status new => assigned
2020-03-25 14:59 pmarzullo Assigned To => pmarzullo
2020-03-25 15:00 pmarzullo Description Updated View Revisions
2020-03-25 15:40 pmarzullo Status assigned => resolved
2020-03-25 15:40 pmarzullo Resolution open => fixed
2020-03-25 15:40 pmarzullo Fixed in Version => 3.11.8