View Issue Details

IDProjectCategoryView StatusLast Update
0000048SymmetricDSNew Featurepublic2009-01-08 07:28
ReporterAssigned Tochenson 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.1 
Target Version1.6.0Fixed in Version1.6.0 
Summary0000048: Allow outer nodes in a multi-tier system to be able to connect to the central-most node for registration
DescriptionWhen you have a setup with three tiers with the root being tier 1 and the outer most tier being tier 3 we want to be able to have tier 3 nodes perform registration with tier 1 and receive configuration that will force the tier 3 node to synchronize exclusively with a single, specific tier 2 server. tier 1 node_group = homeoffice tier 2 node_group = region tier 3 node_group = workstation We want workstation nodes to be able to all be configured the same way (by giving them the url of the homeoffice installation for registration purposes) but all be assigned to a specific regional node for scalability purposes. Currently the only way for a workstation to pull the correct configuration is to register with the specific region it is interested in receiving and sending data to. This is because node_group_link is the mechanism by which we sync and all nodes in a group will be synced to unless there is some criteria we can use to route to a specific region. When you attach to a specific region to register you only download the nodes at that region and don't have references to other regional nodes. If we received registration from the homeoffice node then we would have references to all regional nodes.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change