View Issue Details

IDProjectCategoryView StatusLast Update
0000573SymmetricDSBugpublic2012-01-27 16:52
ReporterAssigned Tochenson 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.5.4 
Target Version2.5.5Fixed in Version2.5.5 
Summary0000573: ColumnMatchDataRouter incorrectly parses router expressions with column names that contain 'OR'. e.g. CONCENTRATOR_ID
Description"Get the following error message from the SymmetricDS Server: ColumnMatchDataRouter - The provided column match expression was invalid: CONCENTRAT. The full expression is CONCENTRATOR_ID=:EXTERNAL_ID. The router expression is being parsed using the regular expression ""
|
|
|\s*or\s*|\s*OR\s*"", but \s* means *zero* or more spaces. This means that if a column contains 'OR' then the expression will be incorrectly parsed. I haven't tested as yet but I believe that a more correct regular express would be ""
|
|
|\s+or\s+|\s+OR\s+"") since the \s+ means one or more spaces."
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change