View Issue Details

IDProjectCategoryView StatusLast Update
0000591SymmetricDSBugpublic2012-01-26 14:28
ReporterAssigned To 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.5.8 
Target Version2.5.9Fixed in Version2.5.9 
Summary0000591: Oracle NUMBER(3) isn't java.sql.TINYINT
Description"create_sample.xml: <?xml version=""1.0""?> <!DOCTYPE database SYSTEM ""http://db.apache.org/torque/dtd/database.dtd""> <database name=""sample""> <table name=""test_table""> <column name=""val"" type=""DECIMAL"" size=""3"" /> </table> </database> values to send in slave-scheme can't be greater 128, because org.jumpmind.symmetric.ddl.platform.oracle.OracleModelReader.readColumn(DatabaseMetaDataWrapper, Map) do switch (column.getSizeAsInt()) { case 3 : if (column.getScale() == 0) { column.setTypeCode(Types.TINYINT); } break; ... } This is wrong according to paragraph 8.3.4 from link http://docs.oracle.com/javase/1.5.0/docs/guide/jdbc/getstart/mapping.html. If remove ""case 3:"" from switch-statement then org.jumpmind.symmetric.ddl.alteration.ModelComparator.compareColumns(Table, Column, Table, Column) return not empty list every time you restart SymmetricDS because in ModelComparator (line 337) targetColumn.getTypeCode() return java.sql.Types.TINYINT but sourceColumn.getTypeCode() return java.sql.Types.DECIMAL."
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change