View Issue Details

IDProjectCategoryView StatusLast Update
0000687SymmetricDS ProBugpublic2014-02-02 20:52
ReporterelongAssigned Tochenson 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version3.0.6 
Target Version3.0.7Fixed in Version3.0.7 
Summary0000687: Installation Fail: NPE with client install
DescriptionDuring the initial setup after the software is first installed, if you install a server, then checkmark "Install Client", it fails with the exception below. The server installation fails and the user is stuck in a non-working UI.

com.vaadin.event.ListenerMethod$MethodException: Invocation of method buttonClick in com.jumpmind.symmetric.console.ui.a.n$1 failed.
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:530)
    at com.vaadin.event.EventRouter.fireEvent(EventRouter.java:164)
    at com.vaadin.ui.AbstractComponent.fireEvent(AbstractComponent.java:1219)
    at com.vaadin.ui.Button.fireClick(Button.java:567)
    at com.vaadin.ui.Button.changeVariables(Button.java:223)
    at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.changeVariables(AbstractCommunicationManager.java:1460)
    at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.handleVariableBurst(AbstractCommunicationManager.java:1404)
    at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.handleVariables(AbstractCommunicationManager.java:1329)
    at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.doHandleUidlRequest(AbstractCommunicationManager.java:761)
    at com.vaadin.terminal.gwt.server.CommunicationManager.handleUidlRequest(CommunicationManager.java:296)
    at com.vaadin.terminal.gwt.server.AbstractApplicationServlet.service(AbstractApplicationServlet.java:501)
Caused by: java.lang.NullPointerException
    at com.jumpmind.symmetric.console.ui.a.o.g(InstallFinishedServerScreen.java:65)
    at com.jumpmind.symmetric.console.ui.a.o.c(InstallFinishedServerScreen.java:48)
    at com.jumpmind.symmetric.console.ui.a.n$1.buttonClick(NodeSetupWizard.java:93)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
TagsNo tags attached.

Activities

chenson

2012-06-30 14:14

administrator   ~0000026

I saw this the other day and forgot to fix it. Thx for logging. I'll get it fixed right away.

chenson

2012-07-01 09:12

administrator   ~0000027

There was an open source piece of this that I didn't realize.

Related Changesets

SymmetricDS: master 83986407

2012-07-01 09:10:11

chenson

Details Diff
0000687: Installation Fail: NPE with client install
0000687
mod - symmetric/symmetric-server/src/main/java/org/jumpmind/symmetric/web/SymmetricEngineHolder.java Diff File

Issue History

Date Modified Username Field Change
2012-06-30 08:49 elong New Issue
2012-06-30 14:13 chenson Assigned To => chenson
2012-06-30 14:13 chenson Status new => assigned
2012-06-30 14:14 chenson Note Added: 0000026
2012-06-30 15:34 chenson Status assigned => closed
2012-06-30 15:34 chenson Resolution open => fixed
2012-06-30 15:34 chenson Fixed in Version => 3.0.6.1
2012-06-30 15:34 chenson Target Version => 3.0.6.1
2012-07-01 09:12 chenson Note Added: 0000027
2012-07-01 09:12 chenson Fixed in Version 3.0.6.1 => 3.0.7
2012-07-01 09:12 chenson Target Version 3.0.6.1 => 3.0.7
2014-02-02 20:52 Changeset attached => SymmetricDS trunk r5961
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 83986407