View Issue Details

IDProjectCategoryView StatusLast Update
0000740SymmetricDSBugpublic2014-02-02 20:52
ReporterelongAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0.10 
Target Version3.1.0Fixed in Version3.1.0 
Summary0000740: Symadmin help subcommand missing
DescriptionThe command line of "symadmin help" and "symadmin help subcommand" are broken. Running "symadmin help" should list the summary of the subcommands. Running "symadmin help subcommand" should display the help for that subcommand.
TagsNo tags attached.

Relationships

duplicate of 0000646 closedmhanes Command lines should fail if specified engines file doesn't exist 

Activities

chenson

2012-07-31 08:43

administrator   ~0000045

Are you sure this is broke? Seems to work for me ...

elong

2012-07-31 09:26

developer   ~0000046

Broken on Windows 7.

C:\apps\SymmetricDS-Pro-3.0.10\bin>symadmin help
Log output will be written to ../logs/symmetric.log
You must specify either --engine or --properties
usage: symadmin [-c <arg>] [--debug] [-e <arg>] [-f] [-g <arg>] [-h] [-n <arg>]
       [--noconsole] [--nologfile] [-p <arg>] [-providerClass <arg>] [-s <arg>]
       [-storepass <arg>] [-storetype <arg>] [-v] [-w <arg>]
For more options, use symadmin --help

C:\apps\SymmetricDS-Pro-3.0.10\bin>symadmin help send-sql
Log output will be written to ../logs/symmetric.log
You must specify either --engine or --properties
usage: symadmin [-c <arg>] [--debug] [-e <arg>] [-f] [-g <arg>] [-h] [-n <arg>]
       [--noconsole] [--nologfile] [-p <arg>] [-providerClass <arg>] [-s <arg>]
       [-storepass <arg>] [-storetype <arg>] [-v] [-w <arg>]
For more options, use symadmin --help

elong

2012-07-31 09:28

developer   ~0000047

Chris, are you sure you are using "symadmin help"? The "help" subcommand should provide help pages on other subcommands. Running the "help" subcommand on its own should provide a summary of all subcommands.

chenson

2012-07-31 09:33

administrator   ~0000048

cshenso@newt:~/SymmetricDS-Pro/bin$ ./symadmin help
Log output will be written to ../logs/symmetric.log
symadmin version 3.1.0-SNAPSHOT
Perform administration tasks with SymmetricDS.

Usage: symadmin <subcommand> --engine [engine.name] [options] [args]
       symadmin <subcommand> --properties [properties file] [options] [args]
Type 'symadmin help <subcommand>' for help on a specific subcommand.

Available subcommands:
   open-registration Open registration for a node
   reload-node Reload data at a node (or initial load)
   reload-table Reload data at a node for a table
   export-batch Export batch CSV data from database
   import-batch Import batch CSV data into database
   run-purge Run the purge job
   encrypt-text Encrypt text string
   create-war Create web archive for deployment
   create-sym-tables Create tables required by SymmetricDS
   export-sym-tables Export tables required by SymmetricDS
   sync-triggers Create database triggers
   export-properties Export default properties
   send-sql Send SQL statement to node
   send-schema Send schema change to node
   send-script Send script to node
cshenso@newt:~/SymmetricDS-Pro/bin$ ./symadmin help open-registration
Log output will be written to ../logs/symmetric.log
Usage: symadmin open-registration <node group> <external id>

Open registration for the passed in node group and external id.

Engine options:
      --debug Print debug information in logging.
   -e,--engine <arg> The name of a configured engine. The name should
                           correspond to a engine.name setting in one of the
                           properties files in the engines directory.
   -h,--help Print help with each option and description.
      --noconsole No output will be sent to the console.
      --nologfile No output will be sent to the log file.
   -p,--properties <arg> The properties file with settings for the SymmetricDS
                           engine. If not provided, defaults are used, then
                           overridden with first symmetric.properties in
                           classpath, then overridden with symmetric.properties
                           values in user.home directory.
   -v,--verbose Use verbose format for console output.

Crypto options:
   -providerClass <arg> Class name of alternate crypto provider.
   -storepass <arg> Password for keystore [changeit].
   -storetype <arg> Type of keystore format [jks].

elong

2012-07-31 09:40

developer   ~0000049

Is it fixed in the 3.1.0-SNAPSHOT you are using? I'm using 3.0.10. I don't think it's a Windows issue because if I manually run "java org.jumpmind.symmetric.SymmetricAdmin help" I get the same results.

chenson

2012-07-31 15:38

administrator   ~0000050

Mark fixed this with Issue 646

chenson

2012-07-31 17:37

administrator   ~0000051

I was mistaken. Help looked like it was working in when you had a properties file in the engines directory. When the file is not there, then it behaves like you described. Checking in the fix.

Related Changesets

SymmetricDS: master a66f1256

2012-07-31 17:38:14

chenson

Details Diff
0000740: Symadmin help subcommand missing
0000740
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/AbstractCommandLauncher.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/DbExportCommand.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/DbImportCommand.java Diff File
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/SymmetricAdmin.java Diff File
mod - symmetric-server/src/main/java/org/jumpmind/symmetric/SymmetricLauncher.java Diff File

SymmetricDS: master af054297

2012-07-31 17:45:51

chenson

Details Diff
0000740: Symadmin help subcommand missing
0000740
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/SymmetricAdmin.java Diff File

Issue History

Date Modified Username Field Change
2012-07-29 10:44 elong New Issue
2012-07-31 08:43 chenson Note Added: 0000045
2012-07-31 08:43 chenson Assigned To => elong
2012-07-31 08:43 chenson Status new => assigned
2012-07-31 09:26 elong Note Added: 0000046
2012-07-31 09:28 elong Note Added: 0000047
2012-07-31 09:33 chenson Note Added: 0000048
2012-07-31 09:40 elong Note Added: 0000049
2012-07-31 15:37 chenson Relationship added duplicate of 0000646
2012-07-31 15:37 chenson Status assigned => resolved
2012-07-31 15:37 chenson Fixed in Version => 3.1.0
2012-07-31 15:37 chenson Resolution open => fixed
2012-07-31 15:37 chenson Target Version => 3.1.0
2012-07-31 15:38 chenson Note Added: 0000050
2012-07-31 17:28 chenson Assigned To elong => chenson
2012-07-31 17:28 chenson Status resolved => assigned
2012-07-31 17:37 chenson Note Added: 0000051
2012-07-31 17:38 chenson Status assigned => resolved
2012-08-14 07:57 chenson Status resolved => closed
2014-02-02 20:52 Changeset attached => SymmetricDS trunk r6122
2014-02-02 20:52 Changeset attached => SymmetricDS trunk r6124
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master af054297
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master a66f1256