View Issue Details

IDProjectCategoryView StatusLast Update
0000952SymmetricDSBugpublic2014-06-16 20:27
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.1.11 
Target Version3.6.0Fixed in Version3.6.0 
Summary0000952: Data can be skipped due to aggressive purge on some platforms
DescriptionMySQL uses the max data_id as the next data_id.

If rows 5,6,7,8,9,10 are purged and the next data_id was going to be 11, sym_data_gap would have a gap of 11 to 50,000. The next data_id inserted will be 5 because 5-10 have been purged. data_ids 5-10 will never be routed.

Maybe the solution is to never purge the last data_id?
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master fe2504c6

2014-05-27 10:52:18

chenson

Details Diff
0000952: Data can be skipped due to aggressive purge on some platforms
0000952
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/PurgeService.java Diff File

Issue History

Date Modified Username Field Change
2012-12-12 20:34 chenson New Issue
2012-12-12 20:46 chenson Summary Some database platforms (mysql) will insert data_ids that are one greater than the last. Bad for combo of purge and data_gap. => Data can be skipped due to aggressive purge on some platforms
2012-12-12 20:46 chenson Description Updated View Revisions
2013-06-08 11:13 chenson Target Version => 3.6.0
2014-03-03 09:52 chenson Assigned To => gwilmer
2014-03-03 09:52 chenson Status new => assigned
2014-04-18 13:00 chenson Assigned To gwilmer => chenson
2014-05-27 10:52 chenson Status assigned => resolved
2014-05-27 10:52 chenson Fixed in Version => 3.6.0
2014-05-27 10:52 chenson Resolution open => fixed
2014-05-27 11:00 Changeset attached => SymmetricDS trunk r8313
2014-06-16 20:27 chenson Status resolved => closed
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master fe2504c6