View Issue Details

IDProjectCategoryView StatusLast Update
0000963SymmetricDSBugpublic2019-05-16 11:16
ReportergemisigoAssigned Tojosh-a-hicks 
Priorityhigh 
Status resolvedResolutionfixed 
Product Version3.2.0 
Target Version3.10.3Fixed in Version3.10.3 
Summary0000963: Update and delete does not sync on tables with varbinary primary key
DescriptionWhen a table contains one single varbinary column and it is the primary key, inserts do propagate from source to target but updates and deletions don't.
Steps To ReproduceCreate a table with a single varbinary(13) column and let that be the primary key. Insert a few records.

Inserts will sync, sym_data table has the varbinary data in row_data and NULL in both pk_data and old_data columns.

Now when you try to delete a record, the logs show there's been a pull that routed 1 data event but nothing changes, the record is not deleted. A peek at sym_data table at the source revealed that the row_data column is NULL (I'm not sure if that's relevant or not) but both pk_data and old_data columns contain empty strings.
Altough it's a bit strange to change the primary key column, I tried to update it just out of curiosity. The change wasn't captured at all.
Additional InformationSource is MSSQL 2k8 R2.
Target is MySQL 5.1.66.
I haven't tried this when there are more than one columns in the tables but I guess that wouldn't change anything as long as the varbinary column is the primary key.
Tagsdata sync

Relationships

related to 0003936 resolvedjosh-a-hicks MSSQL Server to allow varbinary and binary in the where clause (updates and deletes) 
related to 0002563 resolvedjosh-a-hicks When Primary key is binary; SymmetricDS fails capture changes. 

Activities

chenson

2012-12-19 21:46

administrator   ~0000173

Have you tried to set use_stream_lobs on sym_trigger?

gemisigo

2012-12-20 04:40

reporter   ~0000174

I've tried your suggestion of setting use_stream_lobs to 1 but now I get an error message when I try to insert into that table:

Msg 16924, Level 16, State 1, Procedure SYM_ON_I_FOR_VB_PRB_BSDT, Line 3
Cursorfetch: The number of variables declared in the INTO list must match that of selected columns.

chenson

2012-12-20 08:37

administrator   ~0000175

That sounds like 2 bugs. We'll resolve them in the next point release.

gemisigo

2012-12-21 03:52

reporter   ~0000177

Thank you very much. Any info on the release? The roadmap shows schedule for 2012-12-18.

rayp

2018-02-28 14:34

reporter   ~0001135

It looks like we are still running into this problem. Has this really not been fixed since 2012?

elong

2019-05-13 15:35

developer   ~0001472

Fixed for SQL-Server in 0003936 but need to try for MySQL/MariaDB.

Issue History

Date Modified Username Field Change
2012-12-19 06:51 gemisigo New Issue
2012-12-19 21:46 chenson Note Added: 0000173
2012-12-20 04:40 gemisigo Note Added: 0000174
2012-12-20 08:37 chenson Note Added: 0000175
2012-12-20 08:37 chenson Target Version => 3.2.1
2012-12-21 03:52 gemisigo Note Added: 0000177
2013-01-02 21:01 chenson Target Version 3.2.1 => 3.3.0.pre.1
2013-01-29 20:56 chenson Target Version 3.3.0.pre.1 => 3.4.0
2013-03-17 20:56 chenson Target Version 3.4.0 =>
2018-02-28 14:34 rayp Note Added: 0001135
2019-04-23 08:30 elong Tag Attached: data sync
2019-05-13 15:34 elong Relationship added related to 0003936
2019-05-13 15:35 elong Note Added: 0001472
2019-05-13 15:36 elong Assigned To => jaredfrees
2019-05-13 15:36 elong Status new => assigned
2019-05-13 15:36 elong Target Version => 3.10.3
2019-05-14 08:32 elong Relationship added related to 0002563
2019-05-14 11:11 pmarzullo Priority normal => high
2019-05-15 10:55 jaredfrees Assigned To jaredfrees => josh-a-hicks
2019-05-16 11:16 josh-a-hicks Status assigned => resolved
2019-05-16 11:16 josh-a-hicks Resolution open => fixed
2019-05-16 11:16 josh-a-hicks Fixed in Version => 3.10.3