View Issue Details

IDProjectCategoryView StatusLast Update
0000982SymmetricDSBugpublic2014-02-02 20:53
ReporterchensonAssigned Tochenson 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.1 
Target Version3.2.2Fixed in Version3.2.2 
Summary0000982: A conflict is not recorded in sym_incoming_error for sqlite because the database is locked and we use a different connection
DescriptionA conflict is not recorded in sym_incoming_error for sqlite because the database is locked and we use a different connection. Fixing to pass in the transaction used by the data loader for the insertion into sym_incoming_error.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: master cf6dfb7f

2013-01-09 15:36:31

chenson

Details Diff
0000982: A conflict is not recorded in sym_incoming_error for sqlite because the database is locked and we use a different connection
0000982
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/IIncomingBatchService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataLoaderService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/IncomingBatchService.java Diff File

SymmetricDS: master 881bb9cc

2013-01-12 13:59:31

chenson

Details Diff
0000982: A conflict is not recorded in sym_incoming_error for sqlite because the database is locked and we use a different connection
0000982
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataLoaderService.java Diff File

Issue History

Date Modified Username Field Change
2013-01-09 15:36 chenson New Issue
2013-01-09 15:36 chenson Status new => assigned
2013-01-09 15:36 chenson Assigned To => chenson
2013-01-09 15:36 chenson Status assigned => resolved
2013-01-09 15:36 chenson Fixed in Version => 3.2.2
2013-01-09 15:36 chenson Resolution open => fixed
2013-01-12 13:21 chenson Status resolved => closed
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r6751
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r6755
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 881bb9cc
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master cf6dfb7f