View Issue Details

IDProjectCategoryView StatusLast Update
0001469SymmetricDSBugpublic2014-01-06 13:04
ReportercjmullerAssigned Tochenson 
Priorityhigh 
Status closedResolutionfixed 
Product Version3.5.10 
Target Version3.5.13Fixed in Version3.5.13 
Summary0001469: Time and Timestamp field issues on Firebird and Postgres databases
DescriptionI have a "master-slave" replication scenario.
The problem is on the "seconds/milliseconds" portion of a time or timestamp field.
On the master node, I have the original value of '20:43:57.207' (for example) and on the slave node the value was loaded as '20:43:59.070'. The data passed from master to slave without transformation.
I tried to change the 'db.treat.date.time.as.varchar.enabled' key to 'true', but it's not work: when I restart the node I receive a integer conversion error in the batch process.
Another user report similiar problem on Postgres timestamp fields. In his example he has: original values (source) is '2013-11-12 16:32:54.722' and synchronized values (destination) is '2013-11-12 16:32:54.721999'.
Steps To Reproduce1. Create a master-slave replication scenario
2. Create a table with 1 field as time: create table t1 (c1 TIME)
3. Configure SymmetricDS to send the data from master to slave without transformation.
4. Execute the sql statment on master: insert into t1 values ('20:43:57.207');
5. Wait for slave syncronization. Execute the select statment on slave: select c1 from t1;
6. You will see that the data on slave is loaded as '20:43:59.070'.
Additional InformationMy database is Firebird 2.1.1.
TagsNo tags attached.

Activities

elong

2013-11-29 10:14

developer   ~0000399

Could not reproduce on SymmetricDS 3.5.11 and Firebird 2.5-LI-V2.5.2.26539.

chenson

2014-01-04 20:21

administrator   ~0000413

I think this is fixed in 3.5.13. Can you please test and let us know if it fixes your issue?

http://snapshots.repository.codehaus.org/org/jumpmind/symmetric/symmetric-assemble/3.5.13-SNAPSHOT/symmetric-assemble-3.5.13-20140104.050849-7-server.zip

cjmuller

2014-01-05 14:57

reporter   ~0000414

Hi,

I tested with this new version and the issue was fixed.

Thanks a lot !

Issue History

Date Modified Username Field Change
2013-11-19 09:45 cjmuller New Issue
2013-11-29 10:14 elong Note Added: 0000399
2013-12-09 10:48 chenson Target Version => 3.6.0
2014-01-04 20:21 chenson Note Added: 0000413
2014-01-05 14:57 cjmuller Note Added: 0000414
2014-01-05 19:01 chenson Fixed in Version => 3.5.13
2014-01-05 19:01 chenson Target Version 3.6.0 => 3.5.13
2014-01-05 19:01 chenson Status new => resolved
2014-01-05 19:01 chenson Resolution open => fixed
2014-01-05 19:01 chenson Assigned To => chenson
2014-01-06 13:04 chenson Status resolved => closed