View Issue Details

IDProjectCategoryView StatusLast Update
0002261SymmetricDSBugpublic2022-04-26 17:43
Reportermoizhb Assigned Toelong  
Prioritynormal 
Status resolvedResolutionfixed 
Product Version3.7.12 
Target Version3.14.0Fixed in Version3.14.0 
Summary0002261: Schema from Postgres outputs TIMESTAMPTZ that is not compatible with other databases
Description[server-000] - AcknowledgeService - The outgoing batch 001-17 failed. Unknown data type: "TIMESTAMPTZ"; SQL statement:

H2 database does not understand Timestamp with timezone datatype
Steps To ReproduceDuring syncing the schema from server(pg) to client(h2) and if a table has column with data type as timestamp with timezone.
Additional Information----Error on server----

[server-000] - AcknowledgeService - The outgoing batch 001-17 failed. Unknown data type: "TIMESTAMPTZ"; SQL statement:
CREATE TABLE "POSTS"(
    "ID" INTEGER NOT NULL AUTO_INCREMENT,
    "TITLE" VARCHAR(100) NULL,
    "POST" VARCHAR(2147483647) NULL,
    "CREATED_AT" TIMESTAMPTZ,
    "UPDATED_AT" TIMESTAMPTZ,
    PRIMARY KEY ("ID")
) [50004-176]


----Error on client----
Caused by: org.h2.jdbc.JdbcSQLException: Unknown data type: "TIMESTAMPTZ"; SQL statement:
CREATE TABLE "POSTS"(
    "ID" INTEGER NOT NULL AUTO_INCREMENT,
    "TITLE" VARCHAR(100) NULL,
    "POST" VARCHAR(2147483647) NULL,
    "CREATED_AT" TIMESTAMPTZ,
    "UPDATED_AT" TIMESTAMPTZ,
    PRIMARY KEY ("ID")
) [50004-176]

Tagsddl/schema

Relationships

related to 0005280 resolvedelong Table DDL with timestamp and fractional second precision 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2015-04-09 17:42 moizhb New Issue
2019-04-23 17:10 elong Tag Attached: ddl/schema
2019-05-13 20:19 elong Summary Syncing Schema from Postgres to H2 database => Schema from Postgres outputs TIMESTAMPTZ that is not compatible with other databases
2022-04-26 17:41 elong Relationship added related to 0005280
2022-04-26 17:43 elong Assigned To => elong
2022-04-26 17:43 elong Status new => resolved
2022-04-26 17:43 elong Resolution open => fixed
2022-04-26 17:43 elong Fixed in Version => 3.14.0
2022-04-26 17:43 elong Target Version => 3.14.0