View Issue Details

IDProjectCategoryView StatusLast Update
0003242SymmetricDSBugpublic2019-06-25 14:06
ReporterkpatiernoAssigned Touser606 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.8.28 
Target Version3.10.3Fixed in Version3.10.3 
Summary0003242: Running DS as a Windows Service in a folder path that contains whitespace causes error
DescriptionStarting SymmetricDS in a directory that contains whitespace (i.e. 'sym ds', 'install here'...) causes error when trying to start wrapper service > bin/sym_service start
Tagssym/sym_service

Activities

user606

2019-05-09 13:53

  ~0001456

confirmed

space_error.JPG (67,679 bytes)
space_error.JPG (67,679 bytes)

user606

2019-05-09 14:02

  ~0001457

if you install symmetric-pro-<version-number>-setup.jar in a directory with a space the server cannot be started. The control center is initially started after installation but there is an error when you click start server. But the control center won't even open anytime after this. Everything works after you rename the directory without a space.

user606

2019-05-09 16:13

  ~0001459

I was only able to test this on Windows 10

user606

2019-05-13 10:03

  ~0001464

the uninstaller works fine

user606

2019-05-13 10:17

  ~0001465

I am able to open the control center after installation if I run "symcc.bat" as an administrator, but it still gives me this error every time

error2.JPG (40,376 bytes)
error2.JPG (40,376 bytes)

user606

2019-05-13 10:41

 

test2.JPG (78,467 bytes)
test2.JPG (78,467 bytes)
test3.JPG (73,621 bytes)
test3.JPG (73,621 bytes)
test4.JPG (76,810 bytes)
test4.JPG (76,810 bytes)

user606

2019-05-13 15:30

  ~0001471

Last edited: 2019-05-13 16:11

View 2 revisions

I realized the problem with this is contained in SymmetricDS, not the Pro version

user606

2019-05-13 16:11

  ~0001475

error

1.JPG (46,579 bytes)
1.JPG (46,579 bytes)

user606

2019-05-13 17:34

  ~0001477

ProcessBuilder does not want quotes in string arguments even with directories with spaces in name on Windows. If there are spaces in the folder path there is an error because right now quotes are included in the folder path to the symmetric jar file. These quotes are now removed appropriately. Also, getting the location of the symmetric-wrapper.jar file would add in %20 in for any spaces on Windows and other special characters were not decoded in folder names, so these are now fixed.

Related Changesets

SymmetricDS: 3.10 54631b82

2019-05-13 17:34:27

Jared Frees_Home

Details Diff
0003242: Running DS as a Windows Service in a folder path that contains
whitespace causes error

0003242
mod - symmetric-wrapper/src/main/java/org/jumpmind/symmetric/wrapper/WindowsService.java Diff File
mod - symmetric-wrapper/src/main/java/org/jumpmind/symmetric/wrapper/Wrapper.java Diff File
mod - symmetric-wrapper/src/main/java/org/jumpmind/symmetric/wrapper/WrapperService.java Diff File

SymmetricDS: 3.10 9646deb7

2019-05-14 12:36:02

jfrees

Details Diff
0003242: Running DS as a Windows Service in a folder path that contains
whitespace causes error
Remove unused import from testing fix

0003242
mod - symmetric-wrapper/src/main/java/org/jumpmind/symmetric/wrapper/Wrapper.java Diff File

Issue History

Date Modified Username Field Change
2017-08-30 13:46 kpatierno New Issue
2017-08-30 13:46 kpatierno Product Version 3.9.0 => 3.8.28
2019-05-09 13:35 elong Assigned To => user606
2019-05-09 13:35 elong Status new => assigned
2019-05-09 13:53 user606 File Added: space_error.JPG
2019-05-09 13:53 user606 Note Added: 0001456
2019-05-09 14:02 user606 Status assigned => confirmed
2019-05-09 14:02 user606 Note Added: 0001457
2019-05-09 16:13 user606 Note Added: 0001459
2019-05-13 10:03 user606 Note Added: 0001464
2019-05-13 10:17 user606 File Added: error2.JPG
2019-05-13 10:17 user606 Note Added: 0001465
2019-05-13 10:41 user606 File Added: test2.JPG
2019-05-13 10:41 user606 File Added: test3.JPG
2019-05-13 10:41 user606 File Added: test4.JPG
2019-05-13 15:30 user606 Note Added: 0001471
2019-05-13 15:53 user606 Project SymmetricDS Pro => SymmetricDS
2019-05-13 16:10 user606 Summary Installing DS in a file path that contains whitespace stops symcc from running => Running DS as a Windows Service in a folder path that contains whitespace causes error
2019-05-13 16:10 user606 Description Updated View Revisions
2019-05-13 16:11 user606 Note Edited: 0001471 View Revisions
2019-05-13 16:11 user606 File Added: 1.JPG
2019-05-13 16:11 user606 Note Added: 0001475
2019-05-13 17:34 user606 Status confirmed => resolved
2019-05-13 17:34 user606 Resolution open => fixed
2019-05-13 17:34 user606 Fixed in Version => 3.10.3
2019-05-13 17:34 user606 Note Added: 0001477
2019-05-14 09:02 user606 Tag Attached: sym/sym_service
2019-05-14 11:00 Changeset attached => SymmetricDS 3.10 54631b82
2019-05-14 13:00 jfrees Changeset attached => SymmetricDS 3.10 9646deb7
2019-05-14 15:47 elong Target Version => 3.10.3
2019-06-25 14:06 admin Status resolved => closed